Excel’de Eğer formülünün kullanımı (if) Resimli Anlatım – En kolay Anlatımı Bu Yazıda Bulacaksınız

Koşul formülü denilen “eğer” birçok kişiyi daha önce ki sıkıntılı ve zor anlatımlarla kafalarını karıştırıp içinden çıkamayanları korkutmakta. Bundan dolayı daha anlaşılır bir şekilde formülün kullanımını anlatıp bu kişilerin korkularını yenmesi ve aslında ne kadar pratik bir formül ve bir o kadar da kolay olduğunu görmeleri için bu yazıyı hazırladım.

Yazının uzun olması sakın sizi korkutmasın, olabildiğince anlaşılır ve basit olması için uzun bir anlatım metodu seçtim. Zaten kavradığınız noktaları atlayabilirsiniz. Yine de en azından bir kere yazının tamamını okumanız faydanıza olacaktır.

Öncelikle Eğer formülü nedir? Ne işe yarar? Kısaca ondan bahsedelim.

Aşağıda formülü anlamamız için değişik açıklamalar yaptım. Hepsi aslında aynı şeyi ifade eder.

  • Eğer formülü, iki veya daha fazla koşul olduğunda koşulların sonucuna göre yapılması gereken işlemi seçmemizi sağlar.
  • Diğer bir söyleyişle Eğer formülü, bir karşılaştırma sonucuna göre yapılacak işlemi seçmemizi sağlar.
  • Başka bir söyleyişle Eğer formülü, koşullara bağlı olarak farklı olasılıkların sonucunda yapılacak işlemi seçmemizi sağlar.

Formül hakkında bilmemiz gerekenler;

  • Eğer formülü tek başına kullanılmak zorunda değildir.
  • Eğer formülünde aynı anda 7 adet iç içe eğer formülü kullanılabilir.
  • Eğer formülünün içinde başka formüller kullanılabilmektedir.
  • Eğer formülü içinde tırnak içerisinde formül kullanılamaz. Tırnak içinde yazılanlar metin olarak algılanır.

Eğer Formülünün anlayabilmemiz için birden çok değişik şekilde gösterimini yapalım.

=EĞER(Koşul; Doğruysa; Yanlışsa)

=Eğer(Koşul; Şart sağlandı ise yapılacak işlem; Şart sağlanmadı ise yapılacak işlem)

=EğeR(Şart; Doğruysa değer; Yanlışsa değer)

=EğEr(Şart; Evet; Hayır)

 

Örnekle açıklayalım;

1. Örneğimiz; (Basit Eğer Formülü Kullanma Örneği)

Soru: En klasik eğer örneğini verelim. Başarılı ve başarısız öğrencilerin tespiti, sınav sonucu 50 ve üzeri ise başarılı değilse başarısızdır diyelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2>=50;”BAŞARILI”;”BAŞARISIZ”)

Bu formülde B2 hücresine girilen notun 50 geçer notu veya üzerini alıp almadığına bakıyoruz. B2>=50 Daha sonra bu koşula uyuyorsa BAŞARILI uymuyorsa BAŞARISIZ yazdırıyoruz.

eğer formülü 1

 2. Örneğimiz; (Basit Eğer Formülü Kullanma Örneği)

Soru: Yine basit bir örnek verelim. Maliyetinden düşük satışları tespit edip Kar ettiklerimize KAR, Zarar ettiklerimize de ZARAR yazalım.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2>C2;”ZARAR”;”KAR”)

aynı sonucu şu şekilde de bulabilirdik

=EĞER(B2<C2;”KAR”;”ZARAR”)

Bu formülde B2 hücresine girilen değerin C2 hücresine girilen değerden küçük mü büyük mü olduğuna baktık. Şayet küçükse KAR büyükse ZARAR yazdırdık.

eğer formülü 2

 

 3. Örneğimiz; (İç İçe Birden Fazla Eğer Formülü Kullanma Örneği)

Soru: İlk sorudaki Başarılı ve Başarısız olarak tespit etmiş olduğumuz öğrencilerin alacakları belgeleri aşağıdaki gibi tespit edelim.

– Aldığı not 50 puan veya düşükse KALDI yazsın

– Aldığı not 51 ile 70 puan arasında ise GEÇTİ yazsın

– Aldığı not 71 ile 85 puan arasında ise TEŞEKKÜR BELGESİ yazsın

– Aldığı not 86 ile 100 puan arasında ise TAKDİR BELGESİ yazsın

(Gerçekte belge puan durumlarını unuttuğum için rastgele belirledim).

 

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2<=50;”KALDI”;EĞER(B2<=70;”GEÇTİ”;EĞER(B2<=85;”TEŞEKKÜR BELGESİ”;”TAKDİR BELGESİ”)))

Bu formülde öncelikle B2 hücresine girilen değerin 70 puandan düşük ve eşit olup olmadığına baktık. Düşük veya eşitse KALDI yazdık, şayet değilse 70 puandan düşük olup olmadığına baktık düşük veya eşitse bu sefer GEÇTİ yazdırdık, yine değilse bu sefer de 85 puana eşit ve düşük olup olmadığına baktık. Düşükse TEŞEKKÜR BELGESİ yazdırdık. Şartı yine karşılamıyorsa bu sefer son seçenek olduğundan TAKDİR BELGESİ yazdırdık.

eğer formülü 3

Karışık gibi görünse de bir defa dikkatle incelediğinizde aslında aynı şeyi tekrar ettiğimizi ve olayın ne kadar basit olduğunu çok rahat anlayacaksınız.

4. Örneğimiz; (Farklı formüllerle Eğer formülünü birlikte kullanmak)

Soru: Hücreye girilmiş değerlerin 1 ila 20 değeri arasında olup olmadığını tespit edelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(VE(A2>1;A2<20);”Değer 1 ila 20 arasındadır”;”Değer belirlenen ölçülerin dışındadır”)

Bu formülde A2 hücresine girilen değerlerin 1 ila 20 arasında olup olmadığını kontrol ettik. Şayet 1 ila 20 arasında ise Değer 1 ila 20 arasındadır yazdırdık. Değilse Değer belirlenen ölçülerin dışındadır yazdırdık.

eğer formülü 4

 5. Örneğimiz; (Farklı formüllerle Eğer formülünü birlikte kullanmak)

Soru: Hücrelere girilmiş 1 ve 2 değerlerinin bulunduğu hücreleri tespit edelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(YADA(A2=1;B2=2);”BULUNDU”;”FARKLI”)

Bu formülde A2 hücre değerinin 1 olduğu ya da B2 hücre değerinin 2 olduğu durumda BULUNDU yazdık. Şayet her iki değerde farklı ise FARKLI yazdırdık.

eğer formülü 5

 

Umarım anlatımda başarılı olmuşumdur. Örnekleri bu formülde en çok kullanılabilecek örnekler hangileridir diye düşünerek yazmaya gayret ettim. Hala sıkıntı yaşadığınız durumları sormaktan lütfen çekinmeyin.

131 Yorum “Excel’de Eğer Formülünün Kullanımı (if) Resimli Anlatım – En Kolay Anlatımı Bu Yazıda Bulacaksınız”

  1. isim ... dedi ki:

    7 şartli eğer formülü nasıl yapabiliriz.

  2. Barbaros dedi ki:

    Merhaba;

    Bir prim ve hedef tablosu oluşturmaya çalışıyorum. Bir iki formülde takıldım. yardımcı olursanız sevinirim.

    %80’den aşağısına 0 TL
    %80-90 arası hedefe 100 TL
    %90-100 arası hedefe 150 TL
    %100-110 arası hedefe 250 TL
    %110-120 arası hedefe D20 hücresi*0,0101
    %120-125 arası hedefe D20 hücresi*0,0125
    %125 üzeri hedefe 500 TL

    • Bir Kul dedi ki:

      A B C D
      AD SOYAD YÜZDE TL
      ALİ 71 0
      FATMA 76 0
      MEHMET 81 100
      MUHAMMED 86 100
      AYŞE 91 150
      KADİR 96 150
      MAHMUT 101 250
      RIZA 106 250
      YUNUS 111 0
      ENES 116 0
      MURAT 121 0
      VEDAT 126 500

      D20
      (Buraya istediğiniz değeri girdiğinizde 110-125 arası 0 çıkmayacaktır)

      C2’den itibaren TL kısmına gireceğiniz kod:
      =EĞER(B2<80;0;EĞER(B2<90;100;EĞER(B2<100;150;EĞER(B2<110;250;EĞER(B2<120;D20*0,0101;EĞER(B2<125;D20*0,0125;500))))))