//

Excel’de Eğer formülünün kullanımı (if) Resimli Anlatım – En kolay Anlatımı Bu Yazıda Bulacaksınız

Koşul formülü denilen “eğer” birçok kişiyi daha önce ki sıkıntılı ve zor anlatımlarla kafalarını karıştırıp içinden çıkamayanları korkutmakta. Bundan dolayı daha anlaşılır bir şekilde formülün kullanımını anlatıp bu kişilerin korkularını yenmesi ve aslında ne kadar pratik bir formül ve bir o kadar da kolay olduğunu görmeleri için bu yazıyı hazırladım.

Yazının uzun olması sakın sizi korkutmasın, olabildiğince anlaşılır ve basit olması için uzun bir anlatım metodu seçtim. Zaten kavradığınız noktaları atlayabilirsiniz. Yine de en azından bir kere yazının tamamını okumanız faydanıza olacaktır.

Öncelikle Eğer formülü nedir? Ne işe yarar? Kısaca ondan bahsedelim.

Aşağıda formülü anlamamız için değişik açıklamalar yaptım. Hepsi aslında aynı şeyi ifade eder.

  • Eğer formülü, iki veya daha fazla koşul olduğunda koşulların sonucuna göre yapılması gereken işlemi seçmemizi sağlar.
  • Diğer bir söyleyişle Eğer formülü, bir karşılaştırma sonucuna göre yapılacak işlemi seçmemizi sağlar.
  • Başka bir söyleyişle Eğer formülü, koşullara bağlı olarak farklı olasılıkların sonucunda yapılacak işlemi seçmemizi sağlar.

Formül hakkında bilmemiz gerekenler;

  • Eğer formülü tek başına kullanılmak zorunda değildir.
  • Eğer formülünde aynı anda 7 adet iç içe eğer formülü kullanılabilir.
  • Eğer formülünün içinde başka formüller kullanılabilmektedir.
  • Eğer formülü içinde tırnak içerisinde formül kullanılamaz. Tırnak içinde yazılanlar metin olarak algılanır.

Eğer Formülünün anlayabilmemiz için birden çok değişik şekilde gösterimini yapalım.

=EĞER(Koşul; Doğruysa; Yanlışsa)

=Eğer(Koşul; Şart sağlandı ise yapılacak işlem; Şart sağlanmadı ise yapılacak işlem)

=EğeR(Şart; Doğruysa değer; Yanlışsa değer)

=EğEr(Şart; Evet; Hayır)

 

Örnekle açıklayalım;

1. Örneğimiz; (Basit Eğer Formülü Kullanma Örneği)

Soru: En klasik eğer örneğini verelim. Başarılı ve başarısız öğrencilerin tespiti, sınav sonucu 50 ve üzeri ise başarılı değilse başarısızdır diyelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2>=50;”BAŞARILI”;”BAŞARISIZ”)

Bu formülde B2 hücresine girilen notun 50 geçer notu veya üzerini alıp almadığına bakıyoruz. B2>=50 Daha sonra bu koşula uyuyorsa BAŞARILI uymuyorsa BAŞARISIZ yazdırıyoruz.

eğer formülü 1

 2. Örneğimiz; (Basit Eğer Formülü Kullanma Örneği)

Soru: Yine basit bir örnek verelim. Maliyetinden düşük satışları tespit edip Kar ettiklerimize KAR, Zarar ettiklerimize de ZARAR yazalım.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2>C2;”ZARAR”;”KAR”)

aynı sonucu şu şekilde de bulabilirdik

=EĞER(B2<C2;”KAR”;”ZARAR”)

Bu formülde B2 hücresine girilen değerin C2 hücresine girilen değerden küçük mü büyük mü olduğuna baktık. Şayet küçükse KAR büyükse ZARAR yazdırdık.

eğer formülü 2

 

 3. Örneğimiz; (İç İçe Birden Fazla Eğer Formülü Kullanma Örneği)

Soru: İlk sorudaki Başarılı ve Başarısız olarak tespit etmiş olduğumuz öğrencilerin alacakları belgeleri aşağıdaki gibi tespit edelim.

– Aldığı not 50 puan veya düşükse KALDI yazsın

– Aldığı not 51 ile 70 puan arasında ise GEÇTİ yazsın

– Aldığı not 71 ile 85 puan arasında ise TEŞEKKÜR BELGESİ yazsın

– Aldığı not 86 ile 100 puan arasında ise TAKDİR BELGESİ yazsın

(Gerçekte belge puan durumlarını unuttuğum için rastgele belirledim).

 

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2<=50;”KALDI”;EĞER(B2<=70;”GEÇTİ”;EĞER(B2<=85;”TEŞEKKÜR BELGESİ”;”TAKDİR BELGESİ”)))

Bu formülde öncelikle B2 hücresine girilen değerin 70 puandan düşük ve eşit olup olmadığına baktık. Düşük veya eşitse KALDI yazdık, şayet değilse 70 puandan düşük olup olmadığına baktık düşük veya eşitse bu sefer GEÇTİ yazdırdık, yine değilse bu sefer de 85 puana eşit ve düşük olup olmadığına baktık. Düşükse TEŞEKKÜR BELGESİ yazdırdık. Şartı yine karşılamıyorsa bu sefer son seçenek olduğundan TAKDİR BELGESİ yazdırdık.

eğer formülü 3

Karışık gibi görünse de bir defa dikkatle incelediğinizde aslında aynı şeyi tekrar ettiğimizi ve olayın ne kadar basit olduğunu çok rahat anlayacaksınız.

4. Örneğimiz; (Farklı formüllerle Eğer formülünü birlikte kullanmak)

Soru: Hücreye girilmiş değerlerin 1 ila 20 değeri arasında olup olmadığını tespit edelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(VE(A2>1;A2<20);”Değer 1 ila 20 arasındadır”;”Değer belirlenen ölçülerin dışındadır”)

Bu formülde A2 hücresine girilen değerlerin 1 ila 20 arasında olup olmadığını kontrol ettik. Şayet 1 ila 20 arasında ise Değer 1 ila 20 arasındadır yazdırdık. Değilse Değer belirlenen ölçülerin dışındadır yazdırdık.

eğer formülü 4

 5. Örneğimiz; (Farklı formüllerle Eğer formülünü birlikte kullanmak)

Soru: Hücrelere girilmiş 1 ve 2 değerlerinin bulunduğu hücreleri tespit edelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(YADA(A2=1;B2=2);”BULUNDU”;”FARKLI”)

Bu formülde A2 hücre değerinin 1 olduğu ya da B2 hücre değerinin 2 olduğu durumda BULUNDU yazdık. Şayet her iki değerde farklı ise FARKLI yazdırdık.

eğer formülü 5

 

Umarım anlatımda başarılı olmuşumdur. Örnekleri bu formülde en çok kullanılabilecek örnekler hangileridir diye düşünerek yazmaya gayret ettim. Hala sıkıntı yaşadığınız durumları sormaktan lütfen çekinmeyin.

Bu dersin videosunu tam ekran yaparak aşağıdan net bir şekilde izleyebilirsiniz.

 


322 yorum

OĞUZHAN · 14 Eylül 2015 19:59 tarihinde

Merhablar…
Excelde birden çok çalışma sayfasından oluşan bir tablo var. İlk çalışma sayfası veriler ile dolu ve ilk sütun A firması, B firması, C firması gibi değişkenlerden oluşmaktadır. Aşağıdaki gibi örneklenebilir.
1. A Kalem Beyaz 0,5 100 500
2. B Kalem Siyah 0,4 75 350
3. A Kalem Siyah 0,5 100 400
Amacım ikinci çalışma sayfasında filtreleme yapmadan ilk sayfada sadece A firmasının olduğu satırları ikinci sayfaya kopyalaması. Bunu yaparken ilk sayfadaki sıra numarası değil de 1. sıradan başlamasını sağlamaya çalışıyorum. Yani ikinci sayfada şunun oluşması gibi
1. A Kalem Beyaz 0,5 100 500
2. A Kalem Siyah 0,5 100 400

Filtre uygulamak istemiyorum A sütununda 15 e yakın değişken mevcut ve firma bazında adet önem teşkil ediyor.
Filtresiz mümkün değil ise bile ikinci sayfada sadece A firmasına ait verileri nasıl toparlayabilirim? Hücre için formül yazdım ikinci sayfada ilk sütunda firma isimlerini ilk sayfadan alabildim ama aynı sütundaki verileri alamıyorum formülle. Yardımcı olmanızı rica ediyorum.
İlginize teşekkür eder, iyi günler dilerim…

ali · 14 Eylül 2015 19:53 tarihinde

elimde bi hücre var örn. b5 bu hücrede beyaz yazarsa almalı siyaz yazarsa satmalı diye bi formülü nasıl yazabilirim

gamze · 10 Eylül 2015 15:14 tarihinde

yaşı eğitim durum askerlik durumu ve yada
35 lise yapıldı
48 lise yapıldı
29 lise yapılmadı
32 ilkokul yapıldı
39 ilkokul yapıldı
41 lise yapılmadı

eğer ve formulunu kullanarak ve alana (olumlu olması için tum krıterler sağlanması gerekir ) (eğer
yada formulunu kulanarak yada alana (olumlu olması için en az bir kriter sağlanması gerekir) 40 yaşın altında askerliğim yapmış ve lise mezunu olanla için olumlu ve olumsuz yazacak sekilde formul uygulayalım arkadaşlar boyle bi sorum var ne olur yardım edermisiniz

    isim ... · 02 Ocak 2016 10:37 tarihinde

    nbnlşi,

İLKER · 09 Eylül 2015 10:23 tarihinde

ÇOK SAĞOLUN BYLER…

ilkay · 03 Eylül 2015 08:55 tarihinde

merhaba hocam,
benim sorum biraz farklı olacak aşağıda belirtiğim gibi aynı olanları alt alta nasıl rakam yazdırabilirim faklı sipariş numarasına geçildiğinde yine sayma işlemi yine 1 den başlaması gerekiyor.
şimdiden teşekkür ederim,

Sipariş No Kalem No
40388823 1
40388823 2
40388823 3
40388824 1
40388824 2
40388825 1
40388825 2
40388825 3
40388825 4

isim ... · 02 Eylül 2015 16:52 tarihinde

hocam
üst satırda 5-6 firma ismi sol tarafta market ürünleri yazdım. firma ların altına ürünlere ver diği teklifi yazdım. tablonun sağına nasıl formül yazmalıyım ki ortalaması en düşük olan firmayı atsın şimdiden teşekkürler.

isim ... · 28 Ağustos 2015 17:31 tarihinde

HOCAM KONU ŞU:
ÖRNEĞİN;
25 YASINDA 75 KALİTEYE SAHİP BİR KALECİ NİN BONSERVİS DEĞERİ NE KADAR OLUR?
YAŞ ARALIĞI 18-36
MEVKİLER; KALECİ DEFANS ORTA SAHA VE FORVET
OYUNCU KALİTESİ İSE 49’DAN 90′ A KADAR OLUŞTURDUM
ELİMDE BİR TABLO OLSUN YAŞ,KALİTE VE MEVKİSİNİ GİRDİĞİMDE BANA OTOMATIK OLARAK O OYUNCUNUN BONSERVİS BEDELİNİ VERSİN
TEŞEKKÜRLER.

isim ... · 24 Ağustos 2015 14:22 tarihinde

MERHABALAR. PERSONELLER İÇİN YEMEK HAKEDİŞİ HESAPLAMAK İSTİYORUM. 4,5 SAATTEN 11 SAATE KADAR 1 YEMEK ALIYORLAR 11 SAAT VE ÜZERİNDE 2 YEMEK ALIYORLAR. I SÜTUNUNDA ÇALIŞMA SAATLERİ MEVCUT J SÜTUNUNA NASIL BİR FORMÜL KURMALIYIM Kİ SONUÇ ALABİLEYİM. TEŞEKKÜRLER.

as. · 11 Ağustos 2015 23:05 tarihinde

selamlar;

Eğer komutunu içiçe yazarak formüle devam ediyordum fakat dosya formatında izin verilen yuvalama sayısından fazla iç içe değer girdiğimden hata verdi.

Ne yapmalıyım?

TLG · 08 Ağustos 2015 16:47 tarihinde

bir işletme için 3 veri var:

A (değeri C2 de yazılı),
B (değeri C3 de yazılı),
C (değeri C4 de yazılı).

bu işletmenin X olması için
A nın 250 den küçük oması lazım.
aynı zamanda B ve C den en az birinin de 40 dan büyük olmaması lazım.

=EĞER(VE(C2<250;C3<40);"X";"X DEĞİL")
gibi bi formül yazdım ama C4 sınamasını yaptıramadım. Bunu nasıl çözebilirim.

ysn · 29 Temmuz 2015 12:03 tarihinde

Aşağıdaki tabloya göre 0’dan 18 kadar 1,1 yazsın, 18 dahil ve 30’a kadar 1,2 yazsın gibi bir formül lazım yardımcı olur musunuz?
=EĞER(L59=18;L59<30;"1,2")) böyle bir şey yazdım ama olmadı.

DAHİL VE ÜZERİNDE / 'E KADAR
– 18 1,1
18 30 1,2
30 50 1,3
50 80 1,4

Kenan Ayran · 14 Temmuz 2015 12:19 tarihinde

Selam kardeşim formül yerine koşullu biçimlendirme kullan büyük küçük arasında gibi değerlere karşılık renk ataya bılıyorsun

MURAT · 14 Temmuz 2015 03:34 tarihinde

sınıf kitaplığında
7 kitap var,
bu kitaplar 64,56,48,16,32,78,84 sayfadır.
A,B,C,D ve E öğrencileri var. A öğrencisi 64,48,16 sayfalık 3 kitap okuyor.B öğrencisi 16,32,48,56 sayfalık 4 kitap okuyor. C öğrencisi 64,48,16,78,16 sayfalık 5 kitap okuyor…..gibi öğrenci kitabı okudukça öğrencilerin okuduğu kitaplara göre okuduğu kitap sayısını ve sayfa sayısını veren formülü bulmama yardım ederseniz sevinirim.

yalçın · 22 Haziran 2015 11:07 tarihinde

Merhabalar. Hücre içerisinde aradığımız özellik kelimenin “A” harfiyle başlayıp başlamadığını nasıl tanımlayabilirim?

isim ... · 13 Haziran 2015 13:47 tarihinde

erkek 10 kisi kızlar 23 kişi duruma hangisi fazlaysa o yazılması gerek bunun formülü nedir acaba

ercan · 28 Mayıs 2015 10:40 tarihinde

Merhaba hardımcı olabilirmisiniz.

a sütununda kara ve beyaz iki değişken
b sütununda 20 , 25 ve 30 üç değişken

c ye: a da kara ise b de 20 den büykse 50, 25 den büyükse 60, 30 dan büyükse 70 veya beyaz ise 50, 60 ve 70 e +2 ekle

bunu nasıl yazabiliriz.

    Dajder · 29 Mayıs 2015 17:15 tarihinde

    Merhaba Ercan;
    Sorunu yanlış anlamadıysam cevap için formülü aşağıya yazdım. Şayet yanlış anladıysam örnek bir excel dosyasını iletişim bölümünden gönderirsen yardımcı olmaya çalışırım.
    =EĞER(A1=”kara”;(EĞER(B1<25;50;(EĞER(B1<30;60;(EĞER(B1>=30;70))))));EĞER(A1=”beyaz”;(EĞER(B1<25;52;(EĞER(B1<30;62;(EĞER(B1>=30;72))))))))

isim ... · 28 Mayıs 2015 10:29 tarihinde

a sütununda iki değişken var (KARA VE DENİZ gibi) b sütununda farklı değerler var 20 ve 30 gibi
c ye a1 de kara ise ve b1 de 20 den büyük ise 50, 30 dan büyük ise 60 yaz (deniz ise 50 ve 60 a +2 ekle

bunu basıl yazabilirim.

kübra · 27 Mayıs 2015 20:39 tarihinde

çok işime yaradı sağolun

elifmelif.com · 25 Mayıs 2015 20:10 tarihinde

fena degilisti tirnak icinde “zaa x de”tirnagi kapat

Tolga KÖYMEN · 19 Mayıs 2015 14:24 tarihinde

Ömer Bey Selam;

Tablomda veri doğrulama ile yaptığım Tur isimleri var. Örneğin Alanya City Tour, Hamam, Natural Tour, Jeep Safar, vs.. Rehberlerime bu satışlardan jeep safari ve hamam için %5 komisyon diğerleri için %10 komisyon vermek istiyorum.
=EĞER(D8=”RAFTING””DIVING”;K8*5%;K8*10%) formülünü sadece tek bir şart için kullanabiliyorum. işin içine Jeep Safari girince formül sürekli hata veriyor.

Birden fazla şart için nasıl bir formül yazmam gerek?

isim ... · 13 Nisan 2015 13:44 tarihinde

yani demek istediğim şey şuki, numaralar aynı ise mesela aynı yazsın, değil ise farklı yazsın.

isim ... · 13 Nisan 2015 13:41 tarihinde

merhaba, mesela A4579971145 gibi farklı numaralardan oluşan farklı numaralar var. fakat listenin içinde bazı numaralar aynı. bu liste uzun olduğu için tek tek kontrol etme şansım yok. nasıl yaparım?

adem · 11 Nisan 2015 19:31 tarihinde

Merhaba umarım bana yardımcı olabilirsinz

M3 DAY
52,44 17
41,41 35
35,21 6

tahsil edilecek fiyat harekeleri
1-10 arası 0,20 tl
11-30 arası 0,50
30+ 0,70

yukarıda verdiğim detaylar antrepoda kalan mallın ardiye hesaplaması içindir

kaldığı gün x m3 x kaldığı güne göre biçilen değer umarım anlayacağınız dilde anlatabildim

    isim ... · 13 Mayıs 2015 13:52 tarihinde

    ilk olarak günlük ücreti hesaplamak için formülün şöyle olacak bu arada A1 M3, B1 GÜN, C1 GÜNLÜK FİYAT, D1 TOPLAM ALACAĞIN PARA diye başlıkları attım.
    C2 HÜCRESİNE ŞU FORMÜLÜ YAZDIM. =EĞER(B2<=10;"0,20";EĞER(B2=31;”0,70″)))
    yukarıdaki formülü aşağı doğru kopyaladım ve günlük tahsilat ücretlerin çıktı.
    D2 HÜCRESİNEDE BASİT ÇARPIM İŞLEMİNİ YAZDIM.
    =A2*B2*C2

    sonuç olarak 52,44 m3X17GÜNX0,50tl= 445,74TL çıkıyor.

      isim ... · 13 Mayıs 2015 13:54 tarihinde

      formül tam çıkmamış sanki.
      =EĞER(B2<=10;"0,20";EĞER(B2=31;”0,70″)))

        isim ... · 13 Mayıs 2015 13:55 tarihinde

        formül eksik çıkıyor niyeyse ya, ben bunları alt alta yazcam aslında bunlar direk bitişik olacak

        =EĞER(B2<=10;"0,20";
        EĞER(B2=31;”0,70″)))

kemal · 25 Mart 2015 19:58 tarihinde

Dilaver bey merhabalar,

Benim bir sorum olacakti, Elimde 6 adet deger; yapmak istedigim sey eger bu degerler mesela 20 ve 38 arasindaysa bu satirlar sari olsun, degilse degisiklik yapilmasin.
65
55
45
25
15
10
bu konuda yardimci olabilirseniz sevinirim

    isim ... · 14 Temmuz 2015 12:22 tarihinde

    Selam kardeşim formül yerine koşullu biçimlendirme kullan büyük küçük arasında gibi değerlere karşılık renk ataya bılıyorsun

kadir · 10 Mart 2015 18:28 tarihinde

ya yardım etseniz;

Galatasaray=24 gol atmış
Beşiktaş=20 gol atmış
Fenerbahçe=20 gol atmış
Trabzonspor=16 gol atmış bunun cevabını verir misiniz. eğer formülünü

    Dajder · 12 Mart 2015 22:33 tarihinde

    Sorunuz tam olarak anlaşılmadığı için yardımcı olamıyorum.

      SİERRA · 04 Şubat 2016 14:40 tarihinde

      allah allah

Bir cevap yazın

E-posta hesabınız yayımlanmayacak.

This site uses Akismet to reduce spam. Learn how your comment data is processed.