Excel'de İNDİS Fonksiyonun, İngilizce Sürümler için INDEX Formülünün Detaylı Kullanımı

Bu yazının içindeki konular

Microsoft Excel İNDİS Fonksiyonu İngilizce sürümler için INDEX işlevi, bir tablodaki satır ve sütun konumunun kesişimine dayalı olarak tablodaki bir değeri bulur. Bu formül için kullandığımız tablodaki ilk satır 1. satırdır ve tablodaki ilk sütun 1. sütundur.

İNDİS formülü, Excel’de Arama / Başvuru İşlevi olarak kategorize edilen yerleşik bir işlevdir. Genel kullanımında tek başına Excel’de bir çalışma sayfası işlevi olarak kullanılabilir. Ancak bazı durumlarda bir çalışma sayfası işlevi olarak da, İNDİS işlevi, bir çalışma sayfasının bir hücresine başka bir formülün parçası olarak da girilebilir.

İndis Formülünün Kullanımı

İndis formülünün iki farklı kullanım çeşidi mevcuttur. İlki Dizi şeklinde ve İkincisi Başvuru şeklindedir.

=İNDİS(Tablo;Satır Sayısı;Sütun Sayısı)
=İNDİS(Tablo;Satır Sayısı;Sütun Sayısı;Başvuru Alanı)

Argümanlar ve Açıklamaları

Tablo: (Zorunlu) Veri tablosunu içeren bir hücre aralığı

Satır Sayısı: (Zorunlu) Aramak istediğiniz değerin bulunduğu tablodaki satır konumu. Bu, tablodaki göreceli satır konumudur ve çalışma sayfasındaki gerçek satır numarası değildir.

Sütun Sayısı: (İsteğe Bağlı) Aramak istediğiniz değerin bulunduğu tablodaki sütun konumu. Bu, tablodaki göreceli sütun konumudur ve çalışma sayfasındaki gerçek sütun numarası değildir.

Başvuru Alanı: (İsteğe Bağlı) Aramak istediğiniz değerin bulunduğu tablodaki başvuru aralığı.

İndis Fonksiyonunun Kullanım Notları

İNDİS Fonksiyonu: Alfabetik, Sayısal, Tarih vb. herhangi bir veri türünde çalışmaktadır.

MS Office Excel Çalıştığı Versiyonlar: Office 365 için Excel, Excel 2019, Excel 2016, Excel 2013, Mac için Excel 2011, Excel 2010, Excel 2007, Excel 2003, Excel XP, Excel 2000

Kaçıncı Fonksiyonu: İNDİS formülü, bir aralık veya dizide belirli bir konumdaki değeri arar. İNDİS, sıklıkla Kaçıncı formülü ile birlikte kullanılır. KAÇINCI, bir konumu bulur ve bu konumdaki değeri bularak İndis’i besler.

İndis Fonksiyonu Örnek Kullanımları

Örnek Kullanım 1– En basit haliyle aşağıdaki gibi bir dizi formülü ile

=İNDİS(Tablo;Satır Sayısı;Sütun Sayısı)

Excel de İNDİS Fonksiyonu Kullanımı 1

=İNDİS(B2:I6;1;1) // B2'deki değeri bulur
=İNDİS(B2:I6;1;2) // C2'deki değeri bulur
=İNDİS(B2:I6;2;3) // D3'deki değeri bulur
=İNDİS(B2:I6;2;4) // E3'deki değeri bulur
=İNDİS(B2:I6;3;1) // B4'deki değeri bulur

Örnek Kullanım 2– Aşağıdaki gibi bir başvuru formülü ile ise

=İNDİS(Tablo;Satır Sayısı;Sütun Sayısı;Başvuru Alanı)

Excel de İNDİS Fonksiyonu Kullanımı 2

=İNDİS(B2:I8;5;;1) // D4'deki değeri bulur
=İNDİS(B2:I8;1;7;1) // H2'deki değeri bulur
=İNDİS((B3:D7;G3:I7);3;2) // C5'deki değeri bulur
=İNDİS((B2:I8;E3:H7);5;4;2) // F6'daki değeri bulur

İndis Başvuru Fonksiyonu Notlar: 

  • Birden çok aralıklar referanslar noktalı virgül ile ayrılmış ve parantez içinde verilmektedir.
  • Başvurulacak referans sayısı bir veya daha fazla olabilir.
  • Tüm aralıklar tek sayfada olmalıdır, aksi takdirde İNDİS #DEĞER hatası verir. Böyle bir durumda ELEMAN fonksiyonu çözüm olabilmektedir. 

Sitemizden ve Youtube kanalımızdan Ücretsiz Excel Derslerini Sırasıyla takip edebilir ve kendinizi hiçbir başka kaynağa gerek kalmadan Excel konusunda yetiştirebilirsiniz. 

Bunun için tek yapmanız gereken kanalıma abone olup Youtube kanalımdan Sıfırdan MS Office Excel Eğitimleri isimli oynatma listesini takip etmenizdir.

Yada yine WEB sayfam üzerinden Ücretsiz Excel Eğitimler Sıralı Excel Dersleri Excel Videoları isimli sayfamı ziyaret edebilirsiniz. Bu sayfa da ayrıntılı bir şekilde konu başlıklarını ve eklenmiş anlatım ve videoları bulabilirsiniz.

İNDİS Fonksiyonu Kullanımı -1-
İNDİS Fonksiyonu Kullanımı -2-
İNDİS Fonksiyonu Kullanımı -3-

WEB Sitemdeki ve Youtube kanalımdaki tüm içerikleri tamamen ücretsizdir. Ancak ben bu işlem için oldukça zaman ve emek harcıyorum. Sizlerden beklentim dua ve paylaşımlarınızdır. Fakat azda olsa işinize yaradıysa ve ben de destek olmalıyım derseniz hesap bilgilerim aşağıdadır.

DİLAVER AJDER

1 yorum

indirim kodu · 18 Aralık 2020 11:28 tarihinde

youtube kanalınızdan görüp geldim çok teşekkür ederim faydalı ve öğretici bir yazı

Bir cevap yazın

E-posta hesabınız yayımlanmayacak.

This site uses Akismet to reduce spam. Learn how your comment data is processed.