Excel’de Eğer Formülünün Kullanımı (if) Resimli Anlatım – En Kolay Anlatımı Bu Yazıda Bulacaksınız

Excel’de Eğer formülünün kullanımı (if) Resimli Anlatım – En kolay Anlatımı Bu Yazıda Bulacaksınız

Koşul formülü denilen “eğer” birçok kişiyi daha önce ki sıkıntılı ve zor anlatımlarla kafalarını karıştırıp içinden çıkamayanları korkutmakta. Bundan dolayı daha anlaşılır bir şekilde formülün kullanımını anlatıp bu kişilerin korkularını yenmesi ve aslında ne kadar pratik bir formül ve bir o kadar da kolay olduğunu görmeleri için bu yazıyı hazırladım.

Yazının uzun olması sakın sizi korkutmasın, olabildiğince anlaşılır ve basit olması için uzun bir anlatım metodu seçtim. Zaten kavradığınız noktaları atlayabilirsiniz. Yine de en azından bir kere yazının tamamını okumanız faydanıza olacaktır.

Öncelikle Eğer formülü nedir? Ne işe yarar? Kısaca ondan bahsedelim.

Aşağıda formülü anlamamız için değişik açıklamalar yaptım. Hepsi aslında aynı şeyi ifade eder.

  • Eğer formülü, iki veya daha fazla koşul olduğunda koşulların sonucuna göre yapılması gereken işlemi seçmemizi sağlar.
  • Diğer bir söyleyişle Eğer formülü, bir karşılaştırma sonucuna göre yapılacak işlemi seçmemizi sağlar.
  • Başka bir söyleyişle Eğer formülü, koşullara bağlı olarak farklı olasılıkların sonucunda yapılacak işlemi seçmemizi sağlar.

Formül hakkında bilmemiz gerekenler;

  • Eğer formülü tek başına kullanılmak zorunda değildir.
  • Eğer formülünde aynı anda 7 adet iç içe eğer formülü kullanılabilir.
  • Eğer formülünün içinde başka formüller kullanılabilmektedir.
  • Eğer formülü içinde tırnak içerisinde formül kullanılamaz. Tırnak içinde yazılanlar metin olarak algılanır.

Eğer Formülünün anlayabilmemiz için birden çok değişik şekilde gösterimini yapalım.

=EĞER(Koşul; Doğruysa; Yanlışsa)

=Eğer(Koşul; Şart sağlandı ise yapılacak işlem; Şart sağlanmadı ise yapılacak işlem)

=EğeR(Şart; Doğruysa değer; Yanlışsa değer)

=EğEr(Şart; Evet; Hayır)

 

Örnekle açıklayalım;

1. Örneğimiz; (Basit Eğer Formülü Kullanma Örneği)

Soru: En klasik eğer örneğini verelim. Başarılı ve başarısız öğrencilerin tespiti, sınav sonucu 50 ve üzeri ise başarılı değilse başarısızdır diyelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2>=50;”BAŞARILI”;”BAŞARISIZ”)

Bu formülde B2 hücresine girilen notun 50 geçer notu veya üzerini alıp almadığına bakıyoruz. B2>=50 Daha sonra bu koşula uyuyorsa BAŞARILI uymuyorsa BAŞARISIZ yazdırıyoruz.

 2. Örneğimiz; (Basit Eğer Formülü Kullanma Örneği)

Soru: Yine basit bir örnek verelim. Maliyetinden düşük satışları tespit edip Kar ettiklerimize KAR, Zarar ettiklerimize de ZARAR yazalım.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2>C2;”ZARAR”;”KAR”)

aynı sonucu şu şekilde de bulabilirdik

=EĞER(B2<C2;”KAR”;”ZARAR”)

Bu formülde B2 hücresine girilen değerin C2 hücresine girilen değerden küçük mü büyük mü olduğuna baktık. Şayet küçükse KAR büyükse ZARAR yazdırdık.

 

 3. Örneğimiz; (İç İçe Birden Fazla Eğer Formülü Kullanma Örneği)

Soru: İlk sorudaki Başarılı ve Başarısız olarak tespit etmiş olduğumuz öğrencilerin alacakları belgeleri aşağıdaki gibi tespit edelim.

– Aldığı not 50 puan veya düşükse KALDI yazsın

– Aldığı not 51 ile 70 puan arasında ise GEÇTİ yazsın

– Aldığı not 71 ile 85 puan arasında ise TEŞEKKÜR BELGESİ yazsın

– Aldığı not 86 ile 100 puan arasında ise TAKDİR BELGESİ yazsın

(Gerçekte belge puan durumlarını unuttuğum için rastgele belirledim).

 

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2<=50;”KALDI”;EĞER(B2<=70;”GEÇTİ”;EĞER(B2<=85;”TEŞEKKÜR BELGESİ”;”TAKDİR BELGESİ”)))

Bu formülde öncelikle B2 hücresine girilen değerin 70 puandan düşük ve eşit olup olmadığına baktık. Düşük veya eşitse KALDI yazdık, şayet değilse 70 puandan düşük olup olmadığına baktık düşük veya eşitse bu sefer GEÇTİ yazdırdık, yine değilse bu sefer de 85 puana eşit ve düşük olup olmadığına baktık. Düşükse TEŞEKKÜR BELGESİ yazdırdık. Şartı yine karşılamıyorsa bu sefer son seçenek olduğundan TAKDİR BELGESİ yazdırdık.

Karışık gibi görünse de bir defa dikkatle incelediğinizde aslında aynı şeyi tekrar ettiğimizi ve olayın ne kadar basit olduğunu çok rahat anlayacaksınız.

4. Örneğimiz; (Farklı formüllerle Eğer formülünü birlikte kullanmak)

Soru: Hücreye girilmiş değerlerin 1 ila 20 değeri arasında olup olmadığını tespit edelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(VE(A2>1;A2<20);”Değer 1 ila 20 arasındadır”;”Değer belirlenen ölçülerin dışındadır”)

Bu formülde A2 hücresine girilen değerlerin 1 ila 20 arasında olup olmadığını kontrol ettik. Şayet 1 ila 20 arasında ise Değer 1 ila 20 arasındadır yazdırdık. Değilse Değer belirlenen ölçülerin dışındadır yazdırdık.

 5. Örneğimiz; (Farklı formüllerle Eğer formülünü birlikte kullanmak)

Soru: Hücrelere girilmiş 1 ve 2 değerlerinin bulunduğu hücreleri tespit edelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(YADA(A2=1;B2=2);”BULUNDU”;”FARKLI”)

Bu formülde A2 hücre değerinin 1 olduğu ya da B2 hücre değerinin 2 olduğu durumda BULUNDU yazdık. Şayet her iki değerde farklı ise FARKLI yazdırdık.

 

Umarım anlatımda başarılı olmuşumdur. Örnekleri bu formülde en çok kullanılabilecek örnekler hangileridir diye düşünerek yazmaya gayret ettim. Hala sıkıntı yaşadığınız durumları sormaktan lütfen çekinmeyin.

208 responses to “Excel’de Eğer Formülünün Kullanımı (if) Resimli Anlatım – En Kolay Anlatımı Bu Yazıda Bulacaksınız”

  1. Betül dedi ki:

    Merhaba Dilaver bey. =IF(‘[Ekim 2017.xlsx]24 Tv’!C36=0;””;'[Ekim 2017.xlsx]24 Tv’!C36) bu kodu anlamamda yardımcı olabilir misiniz rica etsem

    • DAJDER dedi ki:

      Merhaba Betül hanım,
      Formülünüz de bir hata var ancak açıklama olarak şöyle izah edebilirim.
      Ekim 2017 excel dosyasındaki 24 tv sayfasının c36 hücresindeki değer 0 sa boş bırak değilse aynı dosya aynı sayfa ve aynı hücredeki değeri bu formülü yazdığım yere getir demek istenmiş.

  2. CenkK dedi ki:

    Hocam merhabalar, 4. örnekte kullandığınız =EĞER(VE(A2>1;A2<20);”Değer 1 ila 20 arasındadır”;”Değer belirlenen ölçülerin dışındadır”)formülüne ekleme yapılşabilir mi yine :EĞER ile olacak şekilde. Yani aşağıdaki formülün doğruluğunu kontrol etmneiz mümkünmüdür?
    =IF(AND(D3="Teklif_Takibi";L2=10);C27;"MANUEL GİRİN!";OR(IF(AND(D3="Teklif_Takibi";L2=11);C28;"MANUEL GİRİN!")))
    yani değişen şey olan L2 deki güncel değerler değiştikçe c27, c28, c29….. gidecek şekilde oromatik atama yapması gerekiyor.
    L2=10 ise C27 ye , L2=11 ise C28 ye ,L2=12 ise C28'e şeklinde
    Şimdiden teşekkürler.

    • Dajder dedi ki:

      Merhaba Cenk bey,
      Ekleme elbette yapılabilir. Ancak sizin gösterdiğiniz şekilde değil de iç içe eğer formülünü tekrarlayarak yapabilirsiniz.
      Yani formülünüz
      =EĞER(VE(D3=”Teklif_Takibi”;L2=10);C27;EĞER(VE(D3=”Teklif_
      Takibi”;L2=11);C28;EĞER(VE(D3=”Teklif_Takibi”;L2=12);C29;”MANUEL GİRİN!”))) şeklinde olmalı.

  3. Metin dedi ki:

    office2003 te koşullu biçimlendirmede 3 ten fazla fonksiyon yazdıramıyorum normal mi?

  4. Eren Doğan dedi ki:

    Dilaver Bey
    çalışma saatleriyle ilgili bir excel dosyası hazılamak isiyorum. öncelikle hücre biçimlendirden ss:dd şeklinde saat ayarlamasını yaptım.

    şölye bir şablon oluşturdum ve saat hesaplarının böyle görünmesni istiyorum

    tarih — işe giriş saati- işten çıkış saati — vardiya saati — çalışılan saat
    01/09 19:00 00:00 05:00 04:30
    02/09 19:00 22:30 03:30 03:30
    03/09 19:00 05:00 10:00 09:00

    istediğim şey
    eğer çalışma saati (işe giriş – işten çıkış saati) 5 saatin altındaysa çalışılan saati aynen yazılsın
    eğer çalışma saati 5 saat ise vardiya saatinin yarım saat eksik şekilde yazılsın (04:30 şeklinde)
    eğer 5 saatten fazla ise 1 saat az yazsın (ör: 8 saat çalışılmışsa yan hücreye 7saat yazsın)

    bunun için şöyle bi formül yazdım ancak istediğim sonucu alamadım
    =EĞER(L65;L6-“01:00”)))

    yardımcı olursanız sevinirim.

    Saygılar
    Eren Doğan

    • Eren Doğan dedi ki:

      formül eksik çıkmış

      =EĞER(L65;L6-“01:00”)))

      gerçi zaten doğrusunu siz yazacaksınız ama genede yazayım dedim
      teşekkürler

    • Dajder dedi ki:

      Eren bey Tarih saat fonksiyonlarında eğer vb.. fonksiyonlarda direk işlemi bu gösterdiğiniz şekilde yapamazsınız.
      Anlatımı uzun süreceğinden bu yorum kısmında cevaplamak yerine size excel olarak istediğinizi mail yoluyla gönderdim. Umarım işinizi görürsünüz.
      Diğer arkadaşlar cevabı bizde görseydik derlerse ayrıca konu olarak işleyebilirim.

  5. Necipt dedi ki:

    İyi günlar. İki ayrı sayfada bir birinin aynı bilgileri içeren isim listesi var. Aralarındaki fark 1.listedeki isimler 2.listede farklı sıralarda. Yapmak istediğim. 1.listedeki ismi 2.listede bulup hizasında yazılı bilgileri karşılaştırıp doğru ise değişiklik yapmayacak. Yanlış ise 1.listedeki bilgiyi 2.listede yanlış olan bilgiyle değiştirecek. Dikkat edilmesi gereken 1.liste ile 2.liste farklı kitapların içinde.

    • DAJDER dedi ki:

      Bunun için eğer kullanmanıza gerek yok. =DÜŞEYARA(A1;Sayfa1!A:B;2;0) formülünü kullanabilirsiniz.

  6. Anonim dedi ki:

    Merhaba, excell de metni sütunlara ayırma işlemini yapmaya çalışıyorum. Elimde nerdeyse bi 10 000 satır var. Bu satırlardaki sayılarda noktayla virgülü değiştirmem gerekiyor. Metni sütunlara dönüştür dediğimde bu işlemi yapabiliyorum ancak 10 000 li satırlara gelindiginde 1000 li olan sayılarımda nokta ve virgül beraber olduğu için düzgün ayıramıyor ve yan sütuna değerleri atmaya başlıyor. Hücre biçimlendirmeden denediğimdede bir şey değimedi. Sorunlu kısımları hücre birleştirle halletmeye çalışıyorum ama uzun sürüyor. Metin halindeki listede tüm veriler çift tırnak ve virgülle ayrılmış durumda. O sorunlu 1000 li kısımların başına çift tırnak koyup ayırmayı denediğimde düzgün ayrıldığını fark ettim ama bu kadar uzun sayılar için bunu tek tek yapmam mümkün değil. Ne yapabilirm ? Teşekkür ederim şimdiden.

    • Dajder dedi ki:

      Merhabalar,
      anladığım kadarı ile elle ondalık kısmı ayrılmış rakamlar var elinizde. Aslında excel’de ondalık kısımları belirten nokta ve virgül değerlerini değiştirebiliyorsunuz ama elle yapıldığı için bu çözüm işinize yaramaz. Bunun için rakamları sıralama işlemi yaptıktan sonra yani
      1,01
      10,01
      1000,01
      10000,01
      gibi sıralamaya soktuktan sonra “soldan” formülü ile belli karakterleri ayırmanız ve içlerinde bulunan nokta ve virgülleri ctrl + h ile temizlemeniz arından tekrar birleştirmeniz gerekmektedir. Sorunuzu yanlış anlamadıysam bu şekilde çözüme kavuşabilirsiniz.

  7. Hüseyin dedi ki:

    Merhaba Hocam;

    benim formülüm şu olacak mesela g25,h25,I25 olma üzere yan yana 3 hücre olsun

    =EĞER(H25>84;”GEÇTİ”;”KALDI”) diye bir formül yazdım bu formüle g25=”-” yani tire koyarsam I25 =SINAVA KATILMADI olması için ne yapmamız gerekiyor.formülü yazar mısınız

  8. mehmet çakmak dedi ki:

    Merhaba hocam benim a ve b iki satırım var a ve b satırına girilen sayıların toplamı 20 olduğunda c satırı 1 artsın.
    örnek şöyle: a satırında 10 öğrenci b satırında 20 öğrenci c satırında 1 olacak
    a satırı 15 öğrenci b satırı 28 öğrenci c satırı 2 olacak.

    c satırı 20 eşit ve 20nın katı olduğunda her seferinde 1 artacak sımdıden tsk edıyorum.

  9. İLKİN dedi ki:

    Hocam iyi akşamlar. şimdi benim bir tane sayı sütunum var (200-150-400-300-0,37-0,99) gibi bir de B/A sütunum var yani son olarak iki satır şöyle oluyor(200-A, 150-B, 400-B, 300-B, 0,37-B, 0,99-B) ben bu iki satırda yer alan ‘B’ leri(-) ‘A’ ları (+) yapıcam. söyle bi fotmül yazdım ama olmadı
    =EĞER(G2=”B”; “-“;”+”)

  10. Tuna Arda dedi ki:

    Değerli arkadaşlar bir formülün içinden çıkamadım yardımlarınzı rica ediyorum.

    Elimdeki hazır hücre değerleri aşağıdaki gibi
    A1=100
    B1=18
    C1=118 (A1+B1)
    D1=35 (Kullandığım programın verdiği C1 Hücresinin 118 TL nin karşılığı Euro değer)

    ihtiyacım olan ise
    E1 = 100 Eğer B1 hücresi 0 ‘dan büyükse, D1 / 1,18 rakamının gelmesi, =Eğer(b1>0; d1/1,18) formülüyle bunu yaptım
    ama aynı formülün devamına B1=0 ise D1 ‘e hiç bir işlem yapmadan 35 rakamını aynen getirmesini istiyorum işte bu olmuyor
    Yardımlarını rica ediyorum.

    • Dajder dedi ki:

      Tuna bey formülü şu şekilde düzenlemeniz yeterlidir.
      =EĞER(B1>0; D1/1,18;EĞER(B1=0;D1;”B1 0’dan küçük”))

  11. MURAT YOSUNKAYA dedi ki:

    arkadaslar mrb
    a sutununda yer alan bilgilerin sonlarında ki (- den sonraki) bilgileeri ayırmak istiyorum . sağ dan kes formulu kulllanamıyorum çünkü karakter sayıları tutmuyor. yardımcı olursanız sevinirim teşekkürler. mail adresim [email protected]
    örnek asagıdadır. teşekkürler.
    7414.W6-DGN
    7414.W6-SK
    7414.W9-URT
    7414.X1-SK
    7414.X3-URT
    7414.XK-ORJ
    7414.XQ-YSG
    7414.XR-ORJ
    7414.XT-FT
    7414.XW-FT
    7414.XW-ORJ
    7414.XX-SK
    7414.XY-FT
    7414.Y4-ORJ
    7414.YA-FT
    7414.YE-SK
    7414.YJ-URT
    7414.YL-ORJ-X
    7414.YN-YSG
    7414.YP-ORJ
    7414.YQ-CRFL
    7414.YT-CRFL
    7414.YT-SFWY

  12. Ahmet ÜTKÜR dedi ki:

    Merhaba,
    Bir konuda yardımcı olmanızı isteyeceğim.
    Biz 4 kişilik bir ekiple hediyelik eşya yapıyoruz. Bir tablo yapmak istiyorum ama işin içinden çıkamadım. Örneğin kişiler a, b, c, d olsun. Bir de masraf havuzumuz var. Yapmak istediğim tabloda diyelim ki ürünü a kişisi yaptı (tabloda üretici sütununa ‘a’ yazdık). Ücret kısmına girilen değerimiz de x olsun (X değeri sabit değil, üründen ürüne değişiyor). A kişisi ürünü yaptığı için x’in %50’sini, masraf havuzu tüm x değerlerinin %20’sini, o üründe emeği geçmeyen ama sistemden yine de para alacak olan b, c, d kişileri x’in ayrı ayrı %10’unu alacak.
    Böyle bir hakediş tablosunu nasıl oluşturabilirim. Bu konuda yardımlarınızı rica ediyorum. İyi çalışmalar.

  13. Enes TEMEL dedi ki:

    Merhaba; Örneğin Bir Sütunda %1, %8, ve %18 Olmak Üzere 3 Çeşit Kdv Oranları var, Hemen Yan Sütunda da KDV Tutarları Var,
    Bu Kdv Oranlarına Bağlı Olma Koşulu İle en altta KDV Oranlarına Göre Kdv Tutarlarını Toplatmak İstiyorum (Eğer KDV Oranı % 1 İse Topla) %8 ise topla % 18 ise topla gibi, Yapıyorum ama hata veriyor Yarımcı Olursanız Sevinirim, Teşekkürler

  14. Özlem dedi ki:

    Merhabalar,
    Uzun bir sütunum var ve sütunlarda da a, b, c, d, e vb. ifadelerim var. Bu sütunun hepsi için eğer a ise, bir yere toplam yapılsın, diğerleri ise başka bir yere toplam yapılsın istiyorum. Kaç tane a kaç tane diğerlerinden var onları görmek için.
    EĞER(A1:A90=”a” ; B1=B1+1 ; C1=C1+1) gibi bir formül yazıyorum ama hata veriyor. Yardımcı olur musunuz? Teşekkürler.

    • Dajder dedi ki:

      Merhaba Özlem hanım;
      Bunun birçok sayma yöntemi var. Ancak EĞER(A1:A90=”a” ; B1=B1+1 ; C1=C1+1) bu formül yanlış olur. Sadece formülün bulunduğu hücreye değer vermelisiniz Yani farklı bir hücreye =EĞERSAY(A:A;”a”) & ” adet a var” gibi daha sonra farklı bir hücreye de =EĞERSAY(A:A;”b”) & ” adet b var” gibi

  15. sinem dedi ki:

    Merhaba
    Sorunum ; elimde iki ayri excel tablosu var
    Biri full formülle olusturulmus .
    A sutununda isimler asagi dogru siralı , sag tarafa dogru 1 ayin her gunu 1 2 3 4 … devam ediyor. ve formulle olusturulan rakamlar mevcut.
    Bu rakamlar sistemden cektgm yeni dosya daki rakamlar ile guncellenmeli.
    Bu islem icin nasil bi yol izlemeliyim

    yardimci olurmusunuz 🙏

  16. MEHMET DEMİRCİ dedi ki:

    S.A. yapamadığım bir işlem. yardım bekliyorum.
    A1 hücresinde, b1,c1 ve d1 hücrelerinin toplamı var.
    n1 de son ödeme tarihi.
    h1 hücresinde yapılan ödeme tutarı var.
    yapılan ödeme eksik olduğu zaman E1 hücresinde ne kadar eksik olduğunu görmek istiyorum.
    f1 hücresinde son ödeme tarihinden sonra yapılan ödemeye %5 ceza oranını görmek istiyorum.
    g1 hücresinde yapılan ödeme fazla ise ne kadar fazla olduğunu görmek istiyorum.
    En son olarak yine A1 de bütün bu işlemler yapıldıktan sonra ki toplam tutarı görmek istiyorum.
    Hakkınızı şimdiden helal edin. inşaAllah çok saçma birşey sormamışımdır.

  17. ilyas dedi ki:

    Merhaba benim formülde dönüş saati 19:10 olursa 2/3 değilse 1/3 olsun olarak yapamadım yardımcı olursanız sevinirim

  18. isim ... dedi ki:

    Okuma Var Normal İSE DORU YOKSA YANLIŞ YAZMASINI İSTİYORUM
    Okuma Var Mbs Sisteminde Yok
    Okuma Var Mbs Sisteminde Yok
    Okuma Var Normal
    Okuma Var Normal
    Okuma Var Mbs Sisteminde Yok

    NASIL FORMULU YAZARMISIN

  19. seda dedi ki:

    merhaba
    Benim bi ödevim var da bulamıyorum mesela tabloyu kurduk 300.000 bütçe var eğer bütçe altındaysa alınabilir bütçe üzerindeyse ne kadar daha bütçe gerekli satırda bunun formülünü nasıl kurabilirim

  20. beyazıt dedi ki:

    Arkadaşlar merhaba örneğin 22.04.2017 giriş 23.04.2017 çıkış diye yaptığım iki hücrenin sonucu 1 geceleme versin istiyorum nasıl yapabilirim? Yardımcı olabilecek arkadaşlara şimdiden çok tşkler

    • Dajder dedi ki:

      Beyazıt bey,
      Sanırım iki tarih arasındaki farkı soruyorsunuz. Konu yanlış yere açılmış ama =GÜNSAY(bitiş tarihi;başlangıçtarihi) şeklinde bir formül kullanabilirsiniz.

  21. cobidin dedi ki:

    arkadaşlar benim sıkıntılı bir problemim var az çok eğer formülünü araştıra araştıra kullanmayı öğrendin ama bir yerde takıldım sorunumu çözebilirseniz büyük bir sıkıntıdan kurtarmış olursunuz
    formülü yazdığım hücre d1 dikkat edin

    eğer(a1=b1;c1;d1) yani burada diyorumki tarihler eşitse (a1=b1) c1 hücresindeki değeri al ama yanlışsada doğru iken alınan değerin aynı hücrede kalması (d1) buraya kadar bir problem yok asıl sıkıntı bundan sonra başlıyor

    d1 hücresini a1 b1 e eşit olmadığı zaman aynı formüllü başka bir hücre ile topladığımda her zaman sıfır veriyor değer yazıyor ama toplamları 0 veriyor
    örnek
    a1=01.04.2017 b1=01.04.2017 c1=1 formülü yazdığım hücre d1 hücresi
    EĞER(a1=b1;c1;d1)
    a2=02.04.2017 b1=02.04.2017 c1=1 formülü yazdığım hücre d2 hücresi
    EĞER(a2=b1;c1;d2)
    son olarak d1+d2= 0 veriyor olması gereken 2 olması lazım neden böyle oluyur çözümü varmı bu işin
    şimdiden teşekür ederim

    • Dajder dedi ki:

      Merhaba
      İkinci Formülünüz de b1’e iki farklı değer girmişsiniz. Formülde de b1’i baz almışsınız. Bunu yerine b2’ye değer verip formülde de b1 yerine b2 yazıp denerseniz bir problem kalmayacaktır. Bende acaba ilginç bir durum olabilir mi diye kendim aynı değerlerle formülü yazdım ve sonuç 2 çıkmakta. Sanırım kafanızın dalgın olduğu bir zamana denk geldi.Excel de Tarih çıkarma

      • cobidin dedi ki:

        a1 ve c1 her formülde sabit olması lazım işlemi tekrar deneyip a1 i ayın 03.04.2017 i yapın toplamın 0 olduğunu göreceksiniz ve döngüsel başvuru oluyor. döngüsel başvuru sıkıntı değil ama toplamın 0 olması acayip

        • Dajder dedi ki:

          Anladığım kadarı ile sadece formül sonucundaki toplam kısmı sizi ilgilendiriyor. Bunun için formülün bulunduğu hücreden değer istemezseniz sorununuz çözülür.
          Yani formülde D1 kısmını boş bırakın, zaten kendi bulunduğu hücreye değer verecektir. Else yani değilse kısmını boş bırakmak için formülünüzü =EĞER(A1=B1;C1;) şeklinde düzenlemeniz yeterlidir. Toplama kısmında sonucunuz gözükecektir.

          • cobidin dedi ki:

            Öncelikle ilgilendiniz için çok teşekkür ederim.

            a1 hücresi bugün formüllü her gün değişen bir değer
            c1 hücresi her gün bizim girdiğimiz değişik bir değer için sabit bir hücre
            d1-d2-d3 ise değerleri kaydettiğimiz tablonun hücreleri

            şimdi a1=b1 olduğunda c1 e girdiğimiz değer doğruysa d1 e atıyor. eşitlik bozulduğu zaman yani tarih ertesi güne geçtiği zaman eğer formülünde yanlışsa kısmına d1 hücresini seçiyoruz ki eşitlik durumunda yazdığımız değer, eşitlik bozulduğunda kalabilsin. yanlışsa d1 hücresini seçmezsek tarih değiştiği zaman (a1) d1 hücresi 0 değerini alıyor.bir nevi veri kaydı yaptığımız için biz yanlışsa da d1 hücresini seçmek yoluyla bulduk değerlerimizi kaydetmek için.

            bu durumda döngüsel başvuruya düştüğü için toplamları 0 değerini alıyor. Artık bu yöntemden vazgeçip kayıt makrosu ile yapacağız çünkü formülle çözümünü bulamadık

            ilginizden dolayı tekrar çok teşekkür ederim

      • msdostum dedi ki:

        afferim gız

  22. Ozlem TAN dedi ki:

    Merhaba,
    Aşağıdaki gibi bir örnekde açıklama sütununu IF komutları ile nasıl yazabilirim.
    Kod adet Miktar Açıklama
    10 166 22 Uygun
    10 166 5 Uygun
    10 166 10 Uygun
    20 55 10 Uygun
    20 55 20 Uygun
    20 55 30 Yetersiz
    Teşekkür ederim.

  23. Bilal dedi ki:

    Selamlar,
    A sütununda herhangi bir değer var ise B sütunu evet olacak ( değer sayı, text veya sayı-text olabilir. ) A sütununda herhangi bir değer yok ise B sütunu Hayır olacak.

    değerler sayı olduğunda problem yok ama text olduğunda format sayıda olsa formül çalışmıyor. bunun için özel bir formül mü kullanılıyor ? aklıma IF formula dışında başka formül gelmedi.

    • Dajder dedi ki:

      Merhaba Bilal bey;
      Bunun için iki çeşit formül kullanabilirsiniz. Hangisi kolayınıza gelirse onu değerlendirin.
      İlki =EĞER(A1=””;”Hayır”;”Evet”)
      İkincisi =EĞER(EBOŞSA(A6);”Hayır”;”Evet”)
      Excel Eboşsa Formülü

  24. Mertcan dedi ki:

    Merhaba, ben eğer komutu içerisinde, Ya da kullanıp devamsızlık 5ten yukarı ise harf notuna Dz, ortalama 50den düşük ise FF, Final veya bütünlemeye girmedi ise Gr yazmak istiyorum.Biraz uzun olabilir yardımcı olursanız sevinirim hocam.

  25. murat dedi ki:

    Merhaba excelde şu işi yapmak istiyorum.
    c sütunun daki değer a sütunundaki değer 1 ise c sütunundaki değer b sütnundaki değer olsun. değilse birsey olmasın. bunu nasıl uygulayabilirim.

  26. mustafa selman dedi ki:

    merhabalar,
    aşağıdaki tabloda teslim durumunda “sevkiyat tarihi” sütunu boş olanlarda “teslim durumu”sütununu “BEKLEMEDE” olarak gelmesi için formülde nasıl bir düzeltme yapmalıyım. boş hücreleri sevk edildi olarak algılıyor.

    =EĞER(K2D2;”gecikmeli sevk edildi”;”BEKLEMEDE”))

    sıra sipariş alım tarihi teslim tarihi revize teslim tarihi sekiyat tarihi teslim durumu
    1 21.03.2017 10.04.2017 10.04.2017 12.04.2017 gecikmeli sevk edildi
    2 21.03.2017 10.04.2017 10.04.2017 10.04.2017 sevk edildi
    3 21.03.2017 10.04.2017 10.04.2017 sevk edildi
    4 21.03.2017 10.04.2017 10.04.2017 sevk edildi
    5 21.03.2017 10.04.2017 10.04.2017 sevk edildi

    • Dajder dedi ki:

      Merhaba Mustafa bey,
      excel cevap
      revize teslim tarihine göre durum belirledim. Sanırım istediğiniz bu

      • İLKİN dedi ki:

        hocam iyi akşamlar. şimdi benim bir tane sayı sütunum var (200-150-400-300-0,37-0,99) gibi bir de B/A sütunum var yani son olarak iki satır şöyle oluyor(200-A, 150-B, 400-B, 300-B, 0,37-B, 0,99-B) ben bu iki satırda yer alan ‘B’ leri(-) ‘A’ ları (+) yapıcam. söyle bi fotmül yazdım ama olmadı =EĞER(G2=”B”; “-“;”+”)

  27. Okan dedi ki:

    A HÜCRESİ 100

    B HÜCRESİNE 100 ÜN YÜZDE 30 FAZLASI(130) GERÇEKLEŞİRSE YÜZDE 9 YAZACAK YÜZDE 65 FAZLASI(165) GERÇEKLEŞİRSE YÜZDE 10 YAZACAK İKİ KATI (200)GERÇEKLEŞİRSE YÜZDE 12 YAZACAK

  28. dilekkk dedi ki:

    merhaba bir formül yazılmasını istiyorumda 45 yaşından küçük ise %3 kesinti olacak bunu nasıl yazabilirim excelde

  29. nihat dedi ki:

    selamlar.
    excell de aşağıdaki işlemin formülünü eğer kullanarak nasıl yazabilirim? yardımcı olabilir misiniz?

    a: 50 hedef
    b: 60 gerçekleşme
    c:5 ilave hedef
    d : 10 ikinci ilave hedef
    e: 15 üçüncü ilave hedef
    f: 20 dördüncü ilave hedef
    g: gerçekleşme yüzdesi
    h: istenen (formül yazılacak hücre)

    yazılmasını istediğim şey:
    Eğer b, a*1,045 ten küçük ise g hücresi istenen (h hücresine) yere otomatik gelsin.
    eğer b, (a*1,045 büyük ve a*1,095 den küçük) ise ve ayrıca a+c den de büyük ise g hücresinde yazan yer istenen yerde yer alsın. değilse 104% yazsın
    Eğer b, (a*1,095 ten büyük ve a*1,145 tan küçük) ise ve ayrıca a+d den de büyük ise g hücresinde yazan değer h ye yazılsın. değilse 109% yazsın
    Eğer b, (a*1,145 tan büyük ve 1,195 tan küçük) ise ve ayrıca a+e den de büyük ise g hücresinde yazan değer h ye yazsın. değilse 119 yazsın
    Eğer b, a*1,195 tan büyük ve ayrıca a+f den de büyük ise h de 120 yazsın.

    • Dajder dedi ki:

      Merhaba Nihat,
      Öncelikle maalesef sitemi her gün kontrol etme imkanım olamıyor. Sorunuzu biraz önce fark ettim ve cevap vermek istedim ancak değerlerinizde hata olduğunu fark ettim. Vermiş olduğunuz 2. sorgu yani
      eğer b, (a*1,045 büyük ve a*1,095 den küçük) ise ve ayrıca a+c den de büyük ise g hücresinde yazan yer istenen yerde yer alsın. değilse 104% yazsın
      bu pek mümkün gözükmüyor.
      Yada belki yanlış anlamış olabilirim, bundan dolayı bir örnekle sorunuzu sorarsanız cevaplamaya çalışırım.
      Yinede şunu kontrol edebilirsiniz.
      Eğer Formülü Cevap

      • nihat dedi ki:

        sn. DAJDER, tam olarak istediğim şu şekildedir.
        Hedef(A) Gerçekleşme(B) Gerçekleşme Yüzdesi© Not(D) 105 puan için€
        1,000,000 529,000 0.529 ?? 10 ile 120 arası 100,000

        110 puan için(F) 120 puan için(G) 150 puan için(H)
        200,000 300,000 400,000

        Açıklamalar;
        Hedef gerçekleşme yüzdesi, A * 1.045 den küçük ise C deki oran D de not olarak yazsın
        Hedef gerçekleşme yüzdesi, A * 1.045 den ve ayrıca A+ E den büyük ise ise C deki oran D de not olarak yazsın. Hedef gerçekleşme yüzdesi A*1.045 den büyük ancak A+E den küçük ise D deki not 105 olsun.
        Hedef gerçekleşme yüzdesi, A * 1.095 den ve ayrıca A+ F den büyük ise ise C deki oran D de not olarak yazsın. Hedef gerçekleşme yüzdesi A*1.095 den büyük ancak A+F den küçük ise D deki not 109 olsun.
        Hedef gerçekleşme yüzdesi, A * 1.195 den ve ayrıca A+ G den büyük ise ise C deki oran D de not olarak yazsın. Hedef gerçekleşme yüzdesi A*1.195 den büyük ancak A+G den küçük ise D deki not 119 olsun.
        Hedef gerçekleşme yüzdesi, A * 1.195 den ve ayrıca A+ G den büyük ise ise D deki not 120

  30. Burak dedi ki:

    konuyu bilen üstatlar; sorun şu ki kişilerin doğum tarihleri arasında 01/04/1974 tarihinden büyük ise EVET yaz küçük ise HAYIR yaz formülü nedir acaba?

    • Dajder dedi ki:

      Merhaba aslında konu anlatımı içinde bunun nasıl yapılacağı anlatıldı ama yinede kısaca söyleyeyim.
      A1 Hücresine 01.04.1974 tarihini girdiğinizi ve diğer tarihide A2 Hücresine girdiğinizi farz edelim. Bu durumda A3 Hücresine de =EĞER(A1>A2;"EVET";"HAYIR") formülünü girebilirsiniz. Sadece dikkat etmeniz gereken hücre biçimlerini tarih formatında ayarlamanız dır.

  31. KAN dedi ki:

    SIKINTI YOK SIKINTI YAPMAYIN

  32. ADEM dedi ki:

    mesela bir hücrede müşteri var diğer hücreye eğer bu hücrede müşteri yazıyorsa kalan hesabı 0 yok müşteri yazmıyorsa hesabı 1 yazacağım bir türlü beceremedim.yadımcı olurmusunuz.

  33. MUSTAFA Cİ dedi ki:

    MERHABA A1 DE 50 SAYISI VAR A2 DE 70 A3 TE İSE BİR DEĞER YAZACAĞIM. A3 TEKİ DEĞER A1 DEN AZ VE A2 DEN YÜKSEK OLMAMASI LAZIM. YANİ A3 TEKİ SAYI A1 DEN AZ ÇIKARSA YÜSLT DİYECEK A2 DEN YÜKSEK ÇIKARSA DÜŞÜR DİYECEK BİR KOMUT YAZARMISINIZ

    • Dajder dedi ki:

      Merhaba
      Bunun için sadece eğer formülünü kullanmak istiyorsanız. En basitinden B1 hücresine

      =EĞER(A3<A1;”YÜKSELT”;EĞER(A3>A2;”DÜŞÜR”;” “))

      şeklinde bir formül yazabilirsiniz.

    • HABİB dedi ki:

      =EĞER(A750;A71000;A74000;A7<10000);A7*0,829))))

    • HABİB dedi ki:

      ‘=EĞER(A750;A71000;A74000;A7<10000);A7*0,829))))

  34. isim ... dedi ki:

    Benimde sorum var arkadaşlar
    A1 hücresindeki sayı 50 den küçükse 0,5 ile 50ile1000 arasında ise 0,68 ile 1000 ile 4000 arasında ise 0,75 4000 ile 10.000 arasında ise 0,82 ile çarpsın istiyorum.
    Bunu nasıl yaparım

    • isim ... dedi ki:

      sorunun cevabını buldum ,htiyacı olabilecek arkadaşlar için yazayım dedim :=)
      =EĞER(E6>=1000;(E6*0,75);EĞER(VE(E6>50;E6<1000);(E6*0,68);EĞER(E6<=50;(E6*0,5))))

  35. emre dedi ki:

    merhaba elimde 2 adet gsm liste var farklı excel dosyası sorum şu
    birinci listede olan gsm numarası ikinci listede varmı bunu nasıl kıyaslarım 2 listeyi birbirine karıştırmadan.

  36. DveS dedi ki:

    Merhaba üstat..
    5 farklı isimlerdeki kişiler, farklı aralıklarla 10 farklı ilçeye gidiyor ve bu her ay gittiği ilçe aynı yada farklı olabiliyor.
    Ben istiyorumki birkaç ayın sonunda, X kişi Y ilçesine kaç kez gitmiş..?

    ÖRNEĞİN EXCEL FARKLI HÜCRELERDE.
    —————-
    —-SİNCAN – MAMAK – AKYURT
    ALİ—1———0——–3—-
    GİBİ YAPILABİLİRMİZ ACABA
    ŞİMDİDEN TEŞEKKÜR EDERİM

  37. ucan ınek dedi ki:

    excelı anlamam kac gun surer acaba ben3aydır calısıyorum toplama carpma harıcbır sy yapamıyorum napalım?

    • Dajder dedi ki:

      Aslında Excel’i anlamak çok basittir. Ancak şöyle bir durum var ki, karşınıza çıkacak sorunları sizin içinde öyledir demiyorum ama başkasına çözdürmek yerine ilgili sorunu araştırarak kendiniz çözerseniz hem akılda kalıcı olur hem de bu arada daha çok daha fazla şeyleri de anlamanıza sebep olacaktır.

    • ilkaaa dedi ki:

      bak yavrucuğum çok basit excel nasıl anlamazsınnn heee
      en basit program asıl excel ben uzmanı oldum sen bizim eve gel anlatırım sana 😉

    • ilkaaa dedi ki:

      bak yavrucuğum çok basit excel nasıl anlamazsınnn heee
      en basit program asıl excel ben uzmanı oldum sen bizim eve gel anlatırım sana 😉

  38. isim ... dedi ki:

    SU SORUYU ANLAMDIM. YARDIMCI OLABİLİRMİSİNİZ ?
    (A1=1,A2=4,A3=4)Iken =EĞER(A1>A2;A1+A2;A2+A3)formülünün sonucu kactır

  39. nevzat acar dedi ki:

    Selam arkadaşlar. yeni excel öğreniyorum. Yapmak istediğim şu: bir sutunda giren ve çıkan (yatan ve çekilen) paralar var çekilenler aynı sutunda (-) olarak bulunuyor. Ben bunu 2 sutuna ayırmak istiyorum. Yatanlar a sutununa çekilenler b sutununa. (-) değerlerinde kalkması lazım. Bunu eğer komutuylamı yapmamız lazım. Nasıl bir formül kurmak gerek.

  40. ramazan dedi ki:

    şimdi bir sütunum var değerlerin hepsi (+) pozitif diğer sütunda da B/A kısmı var yani borç olanlar (-) negatif olmak zorunda bu durumda ne kadar formül denemesi yapsam da hata aldım yardımcı olabilir misiniz? 

  41. +54ı+3 dedi ki:

    +85+9439ı34ı34+ı4356

  42. isim ... dedi ki:

    RENK NASIL KIRMIZI OLUYOR?

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak.