Bu yazımızda Excel’de =Çoketopla() yada İngilizcesi (Sumifs) fonksiyonunun kullanımını anlatmaya çalışacağım. Çoketopla formülü birden çok koşula göre toplama yapmak demektir. Daha önce tek bir koşula göre nasıl toplama yapacağımızı anlatmıştık. Buraya tıklayarak o yazımızı da inceleyebilirsiniz.

Formülün açılımı aşağıdaki gibidir.

ÇOKETOPLA(toplama yapılacak yer; koşul uygulanacak yer1; koşul1; koşul uygulanacak yer2; koşul2; …)

Daha kolay anlayabilmek için bir örnek göstermek gerekirse,

Excel ÇOKETOPLA (Sumifs) Fonksiyonu Kullanımı Resimli Anlatım 1

Resimde gördüğünüz gibi bir Excel Listesinde A ve B olmak üzere iki bloktaki değişik metrekarelerde dairelerin fiyatları yazmakta. Burada etopla formülü ile tek koşul belirterek 105 m² lik dairelerin toplam fiyatını görebiliyoruz. Bunun için formülümüz

=ETOPLA(B2:B12;”=105 m²”;C2:C12)

Fakat aynı zamanda ikinci bir koşul belirterek bir toplam yapmak istersek yani A Bloktaki 105 m² lik dairelerin toplam fiyatını öğrenmek istersek burada ikinci bir koşul daha belirtmemiz gerekmekte. Bunun için etopla yetersiz kalıyor ve çoketopla formülünü kullanmamız gerekiyor. bunun formülü’de aşağıdaki gibidir.

=ÇOKETOPLA(C2:C12;B2:B12;”=105 m²”;A2:A12;”A Blok”)

elbette daha ileri düzey listelerde gerekirse çoketopla formülü yardımı ile daha fazla koşul eklenebilir. Formülün ingilizce excel kullananlar için yazılışı =sumifs() şeklindedir.

 



1 yorum

Yasin · 27 Mart 2019 10:48 tarihinde

Merhaba Dilaver Bey,
ÇOKETOPLA formülünü benim tabloda bir türlü mantığını oturtamadım. Genel Üretim sayfasında bulunan verilere göre Sipariş durumu sayfasındaki Extruder, Enjeksiyon, PVC Enjeksiyon, Tedarik ve Montaj kolonlarına kalan adetlerini yazmak istiyorum. Rica etsem inceleyip konu ile ilgili yardımcı olabilir misiniz?

Sipariş Durumu Sayfası
A Kolonu Sipariş No
B Kolonu Extruder
C Kolonu Enjeksiyon
D Kolonu PVC Enjeksiyon
E Kolonu Tedarik
F Kolonu Montaj
G Kolonu Sipariş Miktarı
H Kolonu Üretilen
I Kolonu Kalan
J Kolonu Tamamlanma oranı
K Kolonu Sevk durumu / Açıklama

Genel Üretim Sayfası
A Kolonu Sipariş No
B Kolonu Marka
C Kolonu Ürün Rengi
D Kolonu Ürün Kodu
E Kolonu Ürün Adı
J Kolonu Miktar
L Kolonu Üretim Yeri
U Kolonu Fili Üretim
V Kolonu Kalan Adedi
W Kolonu Durumu

Bir cevap yazın

E-posta hesabınız yayımlanmayacak.

This site uses Akismet to reduce spam. Learn how your comment data is processed.