Excel’de Eğer formülünün kullanımı (if) Resimli Anlatım – En kolay Anlatımı Bu Yazıda Bulacaksınız

Koşul formülü denilen “eğer” birçok kişiyi daha önce ki sıkıntılı ve zor anlatımlarla kafalarını karıştırıp içinden çıkamayanları korkutmakta. Bundan dolayı daha anlaşılır bir şekilde formülün kullanımını anlatıp bu kişilerin korkularını yenmesi ve aslında ne kadar pratik bir formül ve bir o kadar da kolay olduğunu görmeleri için bu yazıyı hazırladım.

Yazının uzun olması sakın sizi korkutmasın, olabildiğince anlaşılır ve basit olması için uzun bir anlatım metodu seçtim. Zaten kavradığınız noktaları atlayabilirsiniz. Yine de en azından bir kere yazının tamamını okumanız faydanıza olacaktır.

Öncelikle Eğer formülü nedir? Ne işe yarar? Kısaca ondan bahsedelim.

Aşağıda formülü anlamamız için değişik açıklamalar yaptım. Hepsi aslında aynı şeyi ifade eder.

  • Eğer formülü, iki veya daha fazla koşul olduğunda koşulların sonucuna göre yapılması gereken işlemi seçmemizi sağlar.
  • Diğer bir söyleyişle Eğer formülü, bir karşılaştırma sonucuna göre yapılacak işlemi seçmemizi sağlar.
  • Başka bir söyleyişle Eğer formülü, koşullara bağlı olarak farklı olasılıkların sonucunda yapılacak işlemi seçmemizi sağlar.

Formül hakkında bilmemiz gerekenler;

  • Eğer formülü tek başına kullanılmak zorunda değildir.
  • Eğer formülünde aynı anda 7 adet iç içe eğer formülü kullanılabilir.
  • Eğer formülünün içinde başka formüller kullanılabilmektedir.
  • Eğer formülü içinde tırnak içerisinde formül kullanılamaz. Tırnak içinde yazılanlar metin olarak algılanır.

Eğer Formülünün anlayabilmemiz için birden çok değişik şekilde gösterimini yapalım.

=EĞER(Koşul; Doğruysa; Yanlışsa)

=Eğer(Koşul; Şart sağlandı ise yapılacak işlem; Şart sağlanmadı ise yapılacak işlem)

=EğeR(Şart; Doğruysa değer; Yanlışsa değer)

=EğEr(Şart; Evet; Hayır)

 

Örnekle açıklayalım;

1. Örneğimiz; (Basit Eğer Formülü Kullanma Örneği)

Soru: En klasik eğer örneğini verelim. Başarılı ve başarısız öğrencilerin tespiti, sınav sonucu 50 ve üzeri ise başarılı değilse başarısızdır diyelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2>=50;”BAŞARILI”;”BAŞARISIZ”)

Bu formülde B2 hücresine girilen notun 50 geçer notu veya üzerini alıp almadığına bakıyoruz. B2>=50 Daha sonra bu koşula uyuyorsa BAŞARILI uymuyorsa BAŞARISIZ yazdırıyoruz.

eğer formülü 1

 2. Örneğimiz; (Basit Eğer Formülü Kullanma Örneği)

Soru: Yine basit bir örnek verelim. Maliyetinden düşük satışları tespit edip Kar ettiklerimize KAR, Zarar ettiklerimize de ZARAR yazalım.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2>C2;”ZARAR”;”KAR”)

aynı sonucu şu şekilde de bulabilirdik

=EĞER(B2<C2;”KAR”;”ZARAR”)

Bu formülde B2 hücresine girilen değerin C2 hücresine girilen değerden küçük mü büyük mü olduğuna baktık. Şayet küçükse KAR büyükse ZARAR yazdırdık.

eğer formülü 2

 

 3. Örneğimiz; (İç İçe Birden Fazla Eğer Formülü Kullanma Örneği)

Soru: İlk sorudaki Başarılı ve Başarısız olarak tespit etmiş olduğumuz öğrencilerin alacakları belgeleri aşağıdaki gibi tespit edelim.

– Aldığı not 50 puan veya düşükse KALDI yazsın

– Aldığı not 51 ile 70 puan arasında ise GEÇTİ yazsın

– Aldığı not 71 ile 85 puan arasında ise TEŞEKKÜR BELGESİ yazsın

– Aldığı not 86 ile 100 puan arasında ise TAKDİR BELGESİ yazsın

(Gerçekte belge puan durumlarını unuttuğum için rastgele belirledim).

 

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2<=50;”KALDI”;EĞER(B2<=70;”GEÇTİ”;EĞER(B2<=85;”TEŞEKKÜR BELGESİ”;”TAKDİR BELGESİ”)))

Bu formülde öncelikle B2 hücresine girilen değerin 70 puandan düşük ve eşit olup olmadığına baktık. Düşük veya eşitse KALDI yazdık, şayet değilse 70 puandan düşük olup olmadığına baktık düşük veya eşitse bu sefer GEÇTİ yazdırdık, yine değilse bu sefer de 85 puana eşit ve düşük olup olmadığına baktık. Düşükse TEŞEKKÜR BELGESİ yazdırdık. Şartı yine karşılamıyorsa bu sefer son seçenek olduğundan TAKDİR BELGESİ yazdırdık.

eğer formülü 3

Karışık gibi görünse de bir defa dikkatle incelediğinizde aslında aynı şeyi tekrar ettiğimizi ve olayın ne kadar basit olduğunu çok rahat anlayacaksınız.

4. Örneğimiz; (Farklı formüllerle Eğer formülünü birlikte kullanmak)

Soru: Hücreye girilmiş değerlerin 1 ila 20 değeri arasında olup olmadığını tespit edelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(VE(A2>1;A2<20);”Değer 1 ila 20 arasındadır”;”Değer belirlenen ölçülerin dışındadır”)

Bu formülde A2 hücresine girilen değerlerin 1 ila 20 arasında olup olmadığını kontrol ettik. Şayet 1 ila 20 arasında ise Değer 1 ila 20 arasındadır yazdırdık. Değilse Değer belirlenen ölçülerin dışındadır yazdırdık.

eğer formülü 4

 5. Örneğimiz; (Farklı formüllerle Eğer formülünü birlikte kullanmak)

Soru: Hücrelere girilmiş 1 ve 2 değerlerinin bulunduğu hücreleri tespit edelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(YADA(A2=1;B2=2);”BULUNDU”;”FARKLI”)

Bu formülde A2 hücre değerinin 1 olduğu ya da B2 hücre değerinin 2 olduğu durumda BULUNDU yazdık. Şayet her iki değerde farklı ise FARKLI yazdırdık.

eğer formülü 5

 

Umarım anlatımda başarılı olmuşumdur. Örnekleri bu formülde en çok kullanılabilecek örnekler hangileridir diye düşünerek yazmaya gayret ettim. Hala sıkıntı yaşadığınız durumları sormaktan lütfen çekinmeyin.

Bu dersin videosunu tam ekran yaparak aşağıdan net bir şekilde izleyebilirsiniz.

 



285 yorum

fatih · 28 Temmuz 2019 21:40 tarihinde

Merhabalar,

Bir sorum olacak, bu konuda destek verebilir misiniz ?
Öncelikle destekleriniz için çok teşekkür ederim,

Sorunum aşağıdaki gibidir,

Excel üzerinde 2 farklı sayfa mevcuttur.
Sayfa 2 nin f3 alanına sayfa2 deki e3 karakterinin sayfa 1 deki g sütünündaki aratılarak eger sonuç doğru ise sayfa 1 deki b sütünündaki uygun alanın gelmesini istemekteyim.

bu durum olabilir mi ?

Murat · 16 Haziran 2019 14:36 tarihinde

Merhaba
Yardımcı olursanız çok sevinirim
İki değeri toplatıp sonuç 200 den büyük ise 200 çıkarsın küçük ise 200 eklesin istiyorum nasıl yaparız

    Dilaver AJDER · 16 Haziran 2019 16:21 tarihinde

    Merhaba Murat;
    İstemiş olduğunuz eğer formülü aşağıdaki gibidir. Burada değerlerin birisi A1 hücresinde diğeri B1 hücresinde olduğu varsayılmıştır.
    =EĞER((A1+B1)>=200;200;(A1+B1)+200)
    Kolay gelsin.

Muhammed · 18 Mayıs 2019 09:02 tarihinde

Dilaver Bey merhaba,

Yorumları okuduğumda tüm arkadaşlara tek tek yardımcı olmaya çalıştığınızı gördüm bunun için tüm arkadaşlar adına öncelikle teşekkür ederim. Benim de bir sorum olacak. İhale gibi bir düzen düşünün. Satır kısmına sırayla A4,A5,A6,A7 ….. diye devam eden malzeme listesi var diğer yanda sütun kısmında o malzemelere fiyat veren firmaların isimleri D3, D4,D5,D6….. gibisinden sıralanıyor. Hangi Firmanın o malzemeye daha uygun fiyat verdiğini nasıl belirleyebilirim. Örneğin hangi firma daha uygun verdiyse onu yeşil diğer firmaların fiyatlarını kırmızı işaretleyebilir miyiz?
Şimdiden vereceğiniz cevap için teşekkür ederim.
Saygılarımla

ENDER · 26 Mart 2019 10:21 tarihinde

merhaba Dilaver Bey,
sizi uğraştırmayayım diye soru cevapları inceledim bulamadım aradığımı. ödeme planı yapıyorum b sütünu firmalardan oluşuyor. I sütunu tutarları veriyor. 600 satır var mesela. arada fatura fatura ödeme yaptığımız için aynı firmadan 3 satır yada 5 satır oluyor. ben aynı firmaların tutarlarını toplasın ama firma tekse fatura değerini getirsin istiyorum.aşağıdaki gibi
Firma Ünvanı Tutar
A FİRMASI 170,11 170,11
B FİRMASI 826,00 826
C FİRMASI 400,00 400
D FİRMASI 360,01
D FİRMASI 320,00
D FİRMASI 59,00 739,01

vaktiniz olurda yardımcı olabilirseniz çok sevinirim. çok teşekkürler

    ENDER · 26 Mart 2019 10:26 tarihinde

    b sütunu firma, c sütünu fatura fatura tutarı, e sütünuna formül girmak istiyorum. a firması tek firma olduğu için fatura tutarını direkt alsın, b ve c firması da öyle. ama d firmasında 3 faturayı toplasın 739,01 toplamını versin e sütununda.

      ENDER · 26 Mart 2019 11:35 tarihinde

      Tüm derdimi anlatayım da olursa mükemmel olur olmazsa can sağlığı;
      yukarıdaki işlem bittikten sonra büyük ödemeden küçük ödemeye doğru sıralıyoruz, mesela;
      B Firması en üstte oluyor 826 tl ödeme, altına D firması 3 satırı kopyalayıp yapıştırıyorum e sütününda 3 fatura toplamı 739 tl sadece. bir önceki sütünda kalıyor 3 faturanın değerleri. sonra C firmasını en sonda A firmasını kopyalayıp yapıştırıyorum alt alta. sırala dediğimde yüksek ödemeler üste geliyor ama aynı firmanın diğer faturaları altta kalıyor. sıralarken hem E Sütünuna göre sıralayacak ama firmaları ayırmayacak. olur mu bilmiyorum. çünkü E sütününda aynı firmaların satırlarının toplamını aldığı için boşluklar oluyor. 600 satır olunca bir sürü firma kopyala yapıştır firmaları tek tek çok zaman alıyor. yapılabilir birşeydir de excell bilmiyoruz tam olarak aslında excell harika bir program. firmaya söyledim kaç kere personel çok boşa zaman kaybediyor bişlmediğinden excell kursu aldırın diye ama pek ilgilenmediler malesef. yardımcı olsanızda olamasanızda tekrar çok teşekkürler. ,nsanlara yardımcı olmaya çalışıyorsunuz yorumları inceledim. keşke sizin gibi insanlar çok olsa birbirimize hep yardım etsek çıkarsız.

        Dilaver AJDER · 26 Mart 2019 12:25 tarihinde

        Merhaba Ender bey;
        Uzun uzun yazmışsınız ama şuan için anlamakta biraz sıkıntı çekiyorum. Ama yapmanız gereken işlem için eğer fonksiyonu altına sorunuzu sorduğunuza göre cevabı yanlış yerde arıyorsunuz.
        İstediğiniz işlemi eğer fonksiyonu ile değil en güzeli özet tablo ile gerçekleştirebilirsiniz. Yada örneğin birinci sorunuz için çok basit bir alttoplam özelliği kullanabilirsiniz. Alttoplam Veri Sekmesi altında sağ tarafta Özet Tablo olayı ise Ekle sekmesi altında en solda pivot table ile çok kolay bir şekilde sonuca ulaşabilirsiniz.

          ÖZKAN · 11 Mayıs 2019 09:47 tarihinde

          merhaba ;

          F34 de bulunan xxx TL Çıkan tutarı 0 dan küçük olduğu için H29 yazsın 0 büyükse C29 yazsın formülü nasıl yapabiliriz.

            Dilaver AJDER · 11 Mayıs 2019 18:37 tarihinde

            Sanırım bu formül işinize yarayacaktır.
            =EĞER(F34<0;H29;C29)

Yasin · 20 Mart 2019 11:09 tarihinde

Merhaba Arkadaşlar,

benim elimdeki excelde iki sayfa var

Birinci sayfada
Tarih C kolonunda
Sipariş Numarası D kolonunda
Ürün Adı E Kolonunda
Başlama Saati F Kolonunda
Bitiş Saati G kolonunda
üretim adedi H kolonunda

ikinci Sayfada
C kolonunda Tarih
D kolonunda Sipariş Numarası
E kolonunda da Ürün adı var.

birinci sayfada Tarih, Sipariş numarası , Ürün Adı , Başlama Saati, bitiş Saati ve üretilen adet var.
ikinci sayfada Tarih, Sipariş numarası , Ürün Adı var
ben ikinci sayfadaki tarih birinci sayfadaki tarih ile eşitse ve Sipariş numarası birinci sayfadaki ile eşitse ve Ürün adı birinci sayfadaki ürün adı ile eşitse birinci sayfadaki başlama Saatini F kolonuna getir demek istiyorum. yardımcı olabilir misiniz?

    Dilaver AJDER · 20 Mart 2019 13:10 tarihinde

    Merhaba Yasin bey;
    2. Sayfadaki F sütununa yazmanız gereken formül aşağıdaki gibidir.
    =EĞER(VE(Sayfa1!C2=Sayfa1!C2;Sayfa2!D2=Sayfa1!D2;Sayfa2!E2=Sayfa1!E2);Sayfa1!F2;"Eşit Değil")

      Yasin · 20 Mart 2019 15:40 tarihinde

      Dilaver Bey Merhaba,
      öncelikle ilginiz için ve hızlı geri dönüşünüz için teşekkür ederim. En azından bu formülün ne işe yaradığını öğrendim sayenizde. Ama aslında benim yapmak istediğim çok koşullu düşeyara gibi bir şey. sayfamın bir tanesinde olan bir datayı diğer tarafa çekmek istiyorum bunun için de if ile almayı denedim. Sonradan bu mantıksız geldi. benim dosyaya formülün uyarlanmış hali şu şekildedir.
      =IF(AND($C:$C=Sayfa1!$A:$A;$D:$D=Sayfa1!$F:$F;$J:$J=Sayfa1!$G:$G);Sayfa1!$I:$I;”Eşit Değil”)

      ENJEKSİYON adlı sayfanın başlıkları
      Buradaki Başlama ve Bitiş saati kolonları boş ben buraları koşullar tutuyorsa Sayfa1 den getirmek istiyorum.

      (A) HAFTA (B)AY (C)Tarih (D)Sip No (E)VRD. (F)Makine No (G)KALIP SINIFI (H)Ürün Ölçüsü (I)Ürün Tipi (J)Ürün Cinsi (K)Başlangıç saati (L)Bitiş Saati (M)Çalışılan saat (N)Çalışılan Dakika (O)Çalışılan Saniye (P)Renk

      Sayfa1 Adlı sayfanın başlıkları
      bu sayfanın tamamı dolu.
      (A)Tarih (B)Vardiya No (C)Makine No (D)Vardiya Ustası (E)Operatör (F)SipNo (G)Ürün Adı (H)Renk (I)Başlama Saati (J)Bitiş Saati

      Yardımcı olsanız da olamasanız da şimdiden teşekkür ederim.
      Saygılarımla

        Dilaver AJDER · 21 Mart 2019 11:31 tarihinde

        Yasin bey kibar bir dille derdinizi anlatmanız ne güzel. Esas ben size teşekkür ederim. Elimden geldiği kadarı ile herkese cevap vermeye çalışıyorum.
        İstemiş olduğunuz şekilde çok koşullu düşeyara fonksiyon olarak excel’de mevcut değil. Ama elbette bu istediğinizi yapamayacağınız anlamına gelmiyor. Bu işlem için her iki sayfadaki A sütununda aramak istediğiniz hücreleri birleştir fonksiyonu ile birleştirip ardından normal bir düşeyara işlemi ile istediğiniz verileri istediğiniz hücreye getirmeniz mümkündür.

          Yasin · 21 Mart 2019 15:36 tarihinde

          Dilaver Bey Tekrardan Merhaba,
          Övgüleriniz için teşekkür ederim. Herkes birbiri ile konuşurken kibar olmalı sizin gibi bilgi ve tecrübesi olan bir insan ile konuşurken özellikle kibar bir dille konuşmamız gerektiğini düşünüyorum. sizlerin buradan cevap verme gibi bir zorunluluğunuz yok iyi niyetli olarak insanlara yardımcı oluyorsunuz. İlgi ve yardımlarınız paha biçilemez derece de övgüye layıktır. söylemiş olduğunuz yöntemi bundan sonra süper bir not olarak aklımda tutacağım. Çünkü kaç gündür bu işi yapmak için uğraşıyorum bu çok güzel bir mantık hiç aklıma gelmedi. ilgi ve yardımlarınız için tekrardan teşekkür ederim.
          iyi çalışmalar

      ENDER · 26 Mart 2019 10:20 tarihinde

      merhaba Dilaver Bey,
      sizi uğraştırmayayım diye soru cevapları inceledim bulamadım aradığımı. ödeme planı yapıyorum b sütünu firmalardan oluşuyor. I sütunu tutarları veriyor. 600 satır var mesela. arada fatura fatura ödeme yaptığımız için aynı firmadan 3 satır yada 5 satır oluyor. ben aynı firmaların tutarlarını toplasın ama firma tekse fatura değerini getirsin istiyorum.aşağıdaki gibi
      Firma Ünvanı Tutar
      A FİRMASI 170,11 170,11
      B FİRMASI 826,00 826
      C FİRMASI 400,00 400
      D FİRMASI 360,01
      D FİRMASI 320,00
      D FİRMASI 59,00 739,01

      vaktiniz olurda yardımcı olabilirseniz çok sevinirim. çok teşekkürler

Jif · 14 Mart 2019 15:52 tarihinde

Merhaba, benim de içinden çıkamadığım bir sorunum var.
Hücreye 480 veya daha küçük bir rakam yazdığımda o yazdığım rakamı 480 den çıkararak bana sonucu vermesini istiyorum.
Mesela hücre içine 47 yazdığımda orada 480-47 nin görünmesini istiyorum. Bunu nasıl yapabilirim?
Her vardiyada toplam 480 dakika var ve benim çalışılmayan süreyi (örnekteki 47) yazıp, toplam çalıştığı süreyi görmem gerekiyor. Anlatabildiğimi umuyorum. Teşekkür ederim.

    Dilaver AJDER · 14 Mart 2019 16:20 tarihinde

    Merhabalar,
    Rakamın yazılacağı hücreyi A1 hücresi kabul edersek yazmanız gereken formül
    =EĞER(A1< =480;480-A1;A1) şeklinde olacaktır.

      Anonim · 14 Mart 2019 16:29 tarihinde

      Hocam süper hızlı cevabınız için çok teşekkür ederim ama sanırım ben ne istediğimi tam olarak anlatamadım.
      Sayfanın bir yerine gizli bir köşeye 480 rakamını yazdım diyelim.
      Sonrasında onlarca hücre var, bu hücrelere yazdığım rakamı bana 480 den çıkararak vermesini istiyorum. Bu sayede toplam çalışılan süreyi bulmuş olacağım. Mesela 480 dakikalık vardiya içinde var olan 10 eleman var diyelim. Ben bu 10 elemanın çalışma saatlerinin karşısına “ÇALIŞMADIKLARI SÜREYİ” yazdığımda, bana çalışmadıkları süreyi 480 den çıkararak çalışılan süreyi vermesini istiyorum.
      Aynı hücre içinde işlem yapmak istediğim için mi beceremiyorum acaba? :S
      İlginiz için tekrar teşekkür ederim.

        Dilaver AJDER · 15 Mart 2019 10:24 tarihinde

        Excel arayüzünde elbette aynı hücre içinde işlem yapamazsınız. Önceki mesajımda yazdığım formüldeki A1 olan hücre değerini değiştirerek istediğiniz yerde kullanabilirsiniz. Yine de sıkıntı çekerseniz sayfamızdaki iletişim bölümünden mail adresiniz, gönderirseniz dosya alış verişi yöntemi ile yardımcı olmaya çalışırım.

mesut · 07 Mart 2019 22:20 tarihinde

merhaba. yardım edermisiniz. a1 ile b1 çarpım sonucu 200 den küçükse sonuç 200 olsun. 200 den büyükse doğru sonucu göstersin.

MEHMET REMZİ · 26 Şubat 2019 14:36 tarihinde

BENİM Bİ SORUM OLACAK
50 DEN BÜYÜK İSE 1 100 DEN BÜYÜK İSE 2 150 DEN BÜYÜK İSE 3 200 DEN BÜYÜK İSE 4 250 DEN BÜYÜK İSE 5 300DEN BÜYÜK İSE 6 350 DEN BÜYÜK İSE 7 400 DEN BÜYÜK İSE 8 450 DEN BÜYÜK İSE 9 500 DEN BÜYÜK İSE 10 550 DEN BÜYÜK İSE 11
BUNU NASIL YAZABİLİRİM

    Dilaver AJDER · 26 Şubat 2019 15:26 tarihinde

    Mehmet bey;
    Verinizin E& hücresinde olduğunu varsayarak en basit şekliyle kullanacağınız formül
    =EĞER(E6>550;11;EĞER(E6>500;10;EĞER(E6>450;9;
    EĞER(E6>400;8;EĞER(E6>350;7;EĞER(E6>300;6;
    EĞER(E6>250;5;EĞER(E6>200;4;EĞER(E6>150;3;
    EĞER(E6>100;2;1))))))))))

    şeklindedir.

bulent · 16 Şubat 2019 22:53 tarihinde

s.a. Dilaver Bey ben 19×11 bir tablo yaptım a dan k stununa kadar 19 satır.
20. satırlar her stunun toplamlarını veriyor A20 =topla(a1:a19)=X …. gibi
L sutunuda her satırın toplamını veriyor. L1 =topla(a1:k1=x ….. gibi
buraya kadar hersey normal sorun yok.

L20 hücresine a20:k20 hücrelerinin toplamıyla L1:L19 hücrelerinin toplamlarının eşit olması durumunda toplama işlemini yapsın yanlışsa “HATA” yada “YANLIŞ” versin istiyorum.
bi arkadaşım bu işte acemi yanlışlıkla formülleri siler bi hata yaparsa farkına varsın istiyorum.
açıkcası formullu hücreleri korumaya alarak halledebiliyorum ama eğer formuluyle gecmiş zamanda bunu yapmıştım diye hatırlıyorum ama çözemedim #DEĞER hatası alıyorum acaba nerde yanlışlık yapıyorum. biraz uzun oldu ama gerçekten kafama takıldı.
denediğim formül bu
=EĞER(L1:L19=A20:K20;A1:K19;”HATA”)
EGER L1:L19 TOPLAMI A20:K20 TOPLAMINA EŞİT İSE A1:K19 SONUCUNU VER; DEĞİLSE “HATA” VER.
YADA
=EĞER(L1:L19=A20:K20;TOPLA(A1:K19);”HATA”)
BUNUDA DENEDİM
YARDIMINIZI BEKLİYORUM TEŞEKKURLER.

tablonun sağında kalan stun yatay satırların toplamını d1:

    Dilaver AJDER · 18 Şubat 2019 20:44 tarihinde

    Bülent bey;
    L20 hücresine yazmanız gereken formül =EĞER(TOPLA(L1:L19)=TOPLA(A1:K19);TOPLA(L1:L19);”HATA”) şeklindedir.

mustafa kahraman · 23 Ocak 2019 15:14 tarihinde

merhabalar;
elimde stok takip programından aldığım liste var, içerisinde ürün giriş tarihi, alış tutarı,ürün modeli ve çıkış tarihi var. Benim yapmak istediğim 01.01.2014-31.12.2017 tarih aralığında stoğa girmiş olup 23.01.2019 tarihinde hala stoktan çıkmamış olan ürün miktarını ve alış tutarını hesaplamak…
yardımınız için teşekkür ediyorum…

MEHMET PAKDİL · 28 Kasım 2018 23:55 tarihinde

Merhaba Dilaver Bey,
İşim ile alakalı bir takip çizelgesi oluşturmak istiyorum.
bir hücreye bir metin girdiğim zaman o günü müteakip 5 gün sonrasına başka bir metin, 5 günden sonra 2 gün sonrasına başka bir metin, takip eden 10 gün sonrasına başka bir metin vs.. gibi
mümkünmüdür acaba.
örnek tablo
tarih
11.11.18 kap/s1
.
.
16.11.18 kb1
.
18.11.18 sal2
.
.
28.11.18 kb2
.
30.11.18 sal3
.
.
30.1.19 kal

yani istediğim şey ben 1 hücreye kap/s1 yazdığımda alta doğru o hücrenin kast ettiği birime hangi gün ne işlem yapılacağını otomatik atamasını istiyorum. zira bu birimlerden fazlasıyla var ve işlem günlerinin takibi karışmaması için böyle bir formüle ihtiyacım var.
ilginiz için teşekkürler.

    Dilaver AJDER · 29 Kasım 2018 16:41 tarihinde

    Mehmet bey, Excel tamamen mantıksal bir yapıda çalışmaktadır. Yani arada mantıksal bağlantılar kesin değilse bir işlem yaptırılamaz. Kast ettiği birimin belli bir özelliği var ise bu konuda Düşeyara yöntemini kullanabilirsiniz.

Anonim · 28 Kasım 2018 12:07 tarihinde

Hocam a1 hücresinde nakit yazıyorsa b1 hücresinin binde birini alıp b1 üstüne toplasın; eğer a1 hücresinde havale yazıyorsa b1 hücresinni binde birbuçuk alıp b1 değerinin üstüne toplayıp yazsın. yardımcı olabilirmisiniz.

    Dilaver AJDER · 28 Kasım 2018 17:00 tarihinde

    Yukarıdaki sorunuz için C1 hücresinde cevabı görmek için C1 hücresine aşağıdaki formülü girebilirsiniz.
    =EĞER(A1=”Nakit”;(B1*0,001)+B1;EĞER(A1=”Havale”;(B1*0,0015)+B1;”Değerde hata var”))

Mustafa Danacıoğlu · 11 Ekim 2018 10:16 tarihinde

Merhabalar, Sn Dilaver Ajder,
Benim sorum şöyle;
B3 hücresinde yazacağım kriter ile C3 hücesindeki kritere göre D3 hücresine bir değer atamak ama bu koşullar ikişer kere var.
Bir fırın için ekmek satışını takip edeceğim,
=EĞER(B3=”Baston”;EĞER(C3=”Tezgah”;1,5;EĞER(B3=”Baston”;EĞER(C3=”Servis”;1;EĞER(B3=”Trabzon”;EĞER(C3=”Tezgah”;5;EĞER(B3=”Trabzon”;EĞER(C3=”Servis”;3,75))))))))
şeklinde yazdığımda Baston cinsi ekmek için değerler doğru geliyor ama Trabzon cinsi ekmek yazdığımda değer kısmına YANLIŞ yazıyor. Yardımınızı arz ederim.

Musa · 24 Ağustos 2018 16:16 tarihinde

Merhaba.Hocam
Sayfa1 ve Sayfa2 var verileri sayfa 1 den çekeceğim . Sayfa1 İş tamamlandı ve Devam ediyor seçeneği var.
Sayfa2 ye sadece devam edenleri çekmek istiyorum. Farklı sayfadan veri alacaksak if nasıl kullanılır. Teşekkür ederim

Anonim · 02 Temmuz 2018 03:45 tarihinde

Merhaba, iş takibi için bir excel tablosu oluşturdum. Burada çeşitli işlerin maliyeti ve kazancı belli. Her iş için bir kod oluşturdum ve açılır kapanır bir liste ile bunları hücre içinde kolayca seçilir hale getirdim. Böylece dosyayı kullanan herkesin aynı iş için aynı kodu kullanması ile takip yapılabilecek. Bu işlerin maliyet ve kazanç miktarları da belli. Bunları da ayrı bir çalışma sayfası oluşturarak yazdım. Maliyetler kurlara bağlı olduğu için her ay fiyatların güncellenmesi gerekiyor. Ben, tek bir formul yazarak, bir iş listeden koduyla seçildiğinde diğer sütunda maliyeti otomatik olarak çıksın istiyorum (yani maliyetin yazdığı diğer çalışma sayfasındaki hücreye gitmeli, orada yazan değeri çekmeli hücreden. Ana çalışma sayfasındaki Formülü sürekli yenilemektense, formülde yer alacak maliyet kalemine ilişkin rakamı, gidip bir hücreden çeksin ve formüle yerleştirsin istiyorum. Böylece ben maliyeti gösteren sayfadaki ilgili hücrede tek bir rakam değiştirmekle, tüm dosyada o hücreye yapılmış referansların topluca değişmesini sağlamak istiyorum. Biraz karışık anlatmış olabilirim, umarım anlaşılıyordur. Bir türlü beceremedim bunu. Yardımcı olursanız memnun olurum.

    Dilaver AJDER · 02 Temmuz 2018 15:39 tarihinde

    Merhabalar,
    Bu işlemi önümüzde bir excel dosyası olmadan neyi nereye yerleştirdiğinizi görmeden yapmamız elbette olmayacak bir iştir. Ancak anladığım kadarı ile istediğiniz işlem için basit bir düşeyara formülü yeterli olacaktır. Bunun için düşeyara formülünü hem resimli hemde videolu anlatımını yaptığım sayfayı incelemenizi öneririm.
    Sayfaya gitmek için tıklayınız.

Ahmet Ümit · 04 Haziran 2018 22:18 tarihinde

Merhaba Dilaver Bey;

A sütununda yazan değer 8’den küçükse A sütunundaki değeri;
8=<A<12 ise A-0,5 değerini
12=<A ise A-1 değerini
yazdırmak istiyorum. Yardımcı olur musunuz?
Teşekkürler.

    Dilaver AJDER · 04 Haziran 2018 23:51 tarihinde

    Merhabalar Ahmet bey,
    Size aşağıdaki gibi bir formül sanırım yardımcı olacaktır.
    =EĞER(VE(A1>=8;A1<12);A1-0,5;EĞER(12<=A1;A1-1;A1))

Kudret İdemci · 02 Haziran 2018 14:03 tarihinde

Bir takvim oluşturdum. Günler sütunu ve açıklama sütunu. Ayda ya da yılda kaç gün çalıştığımı görmek istiyorum. Açıklama sütununa gittiğim turların isimlerini yazıyorum. Belirlediğim bir sütuna Açıklama sütunundaki metni algılayıp Belirlediğim sütuna rakam olarak hep bir artırarak sayı belirtmesini istiyorum. Bu mümkün mü? Mesela A2 1 A2 2 ….A17 16 yazıyor (ay günleri), B2 Kapadokya B3 Kapadokya …B6 Kapadokya B7 Kapadokya. Belirlediğim AM5 e (4) yazmasını istiyorum ve bu her yazdığımda artsın istiyorum. Böyle bir formül mümkün mü? Teşekkür ederim

İbrahim ÇOLAK · 28 Mayıs 2018 12:22 tarihinde

Merhabalar;
B8 hücresinde 300 yazsın, D8 hücresinde 250 yazsın
E8 hücresinde istediğim sonuç; 300 >250 Uygundur.
yada;
B8 hücresinde 250 yazsın, D8 hücresinde 300yazsın
E8 hücresinde istediğim sonuç; 250 < 300 Uygun Değildir.
yani sonuç alanında her zaman B8 ve D8 hücrelerindeki verileri de yazsın. Bunu "Eğer" komutu ile sağlayabiliyor muyuz?

    Dilaver AJDER · 28 Mayıs 2018 13:08 tarihinde

    =EĞER(B8<300;B8&”< "&D8&" Uygun Değildir";B8&">“&D8&” Uygundur”)
    Sanırım eksik bir soru sordunuz ama yine de sorunuz bu şekilde ise formülü şeklinde yazabilirsiniz.

      İbrahim ÇOLAK · 28 Mayıs 2018 13:26 tarihinde

      Cevabınız için teşekkür ederim.
      Kendimi daha iyi ifade edebilmek için size iletişim bölümünden dosya ile birlikte mail attım.
      Şimdiden teşekkürler.

        Dilaver AJDER · 28 Mayıs 2018 14:11 tarihinde

        Mailinize örnek dosyanız hazırlanarak gönderilmiştir.

ABDULLAH KAYA · 22 Mayıs 2018 11:16 tarihinde

Hocam F4 HÜCRESİNDE 0 – 5 YIL YAZARSA H4 HÜCRESİ 16 YAZSIN.. F4 HÜCRESİ 5 – 15 YIL YAZARSA H4 HÜCRESİ 22 YAZSIN… F4 HÜCRESİ 15 – 30 YIL YAZARSA H4 HÜCRESİ 28 YAZSIN BU İŞLEMİ NASIL YAPABİLİRİM SAYGILAR.

    Dilaver AJDER · 26 Mayıs 2018 14:25 tarihinde

    Abdullah bey;
    İstediğiniz işlem için H4 hücresine
    =EĞER(VE(F4>=0;F4<5);16;EĞER(VE(F4>=5;F4<15);22;EĞER(VE(F4>=15;F4<30);28;”Hatalı Değer”)))
    şeklinde formül girebilirsiniz.

Yılmaz Kaydı · 11 Nisan 2018 12:58 tarihinde

merhaba,

17 tane ürün başlığı olan hücrelerin 8 tanesinin kdv si % 18, 1 tanesi % 8, 8 tanesinin kdv si % 0.
Ben burada tek tutar üzerinden hang, üründen satıldıysa ona göre hesaplama yapmak istiyorum. Yardımcı olabilir misiniz?

    enis · 24 Nisan 2018 10:05 tarihinde

    Bu formül için teşekkür ediyorum başarılarınzın devamını diliyorum 🙂

kenan · 04 Nisan 2018 02:01 tarihinde

ben C2 hücresine değer girdiğimde D3 kırmızı…D3 hücresine çıkış yazdığımda C2 hücresinin yeşil olmasını istiyorum. saatlerdir uğraşıyorum. genelde örnekler doğru yanlış veya büyüktür küçüktür gibi olduğundan çözemedim olayı..

Durmuş Demir · 03 Nisan 2018 18:17 tarihinde

Merhaba,
Çok teşekkür ederim. Emeğinize sağlık.

Hakan Erden · 29 Mart 2018 12:22 tarihinde

merhaba şöyle bi formül yazmak istedim yazamadım formül şu mesela A1 hücresi 1 ise B1 hücersi 6, A1 hücresi 2 ise B1 5, A1 hücresi 3 ise B1 4 olacak bu nu nasıl yaparım yardım edermisiniz

    Dajder · 30 Mart 2018 11:31 tarihinde

    Merhaba Hakan bey;
    B1 Hücresine =EĞER(A1=1;6;EĞER(A1=2;5;EĞER(A1=3;4;”A1 hücresine istenilen değer girilmedi”))) formülünü girebilirsiniz.

Anonim · 13 Mart 2018 00:00 tarihinde

bir harika çok faydalıyazıcıdan çıkartarak veya sayfayı indirerek kulanıla bilir bu bilgileri bu siteye sunan kişiye çok teşekkür ediriz

    Dajder · 30 Mart 2018 14:22 tarihinde

    Faydalı olduğuma çok sevindim.

Anonim · 12 Mart 2018 15:11 tarihinde

=EĞER(SAĞDAN(A1;3)=”150″;551;EĞER(SAĞDAN(A1;3)=”100″;551;511))

Anonim · 06 Mart 2018 14:41 tarihinde

yanlışşşşş 😀 😀 D:

    Anonim · 06 Mart 2018 14:41 tarihinde

    yanlış be yaaaaaa 😀 😀 😀

Dexter · 15 Şubat 2018 13:12 tarihinde

iki hücre de tarihi gösteriyorsa, A1 hücresindeki tarih B1 hücresinden büyük ise A1 hücresi yazsın, değil ise B1 yazsın dememiz için ne şekilde bir formül kullanmamız gerekmektedir?

Anonim · 19 Ocak 2018 14:14 tarihinde

excelde eğer formülü kullanarak 5 rakamın son üç hanesindeki rakamlar 150 veya 100 ise 551 yazmasını eğer son üç rakam 100 veya 150 değilse 511 yazmasını istiyorum formülü mailime gönderirseniz sevinirim. Şimdiden teşekkür ederim.

    Dajder · 07 Şubat 2018 11:51 tarihinde

    Sormuş olduğunuz soruya uygun bir formül aşağıdaki gibi olacaktır.
    =EĞER(YADA(SAĞDAN(A2;3)=”150″;SAĞDAN(A2;3)=”100″);551;511)

      emnş · 26 Şubat 2018 14:00 tarihinde

      Gereksiz olduğu için silinmiştir.

      emnş · 26 Şubat 2018 14:00 tarihinde

      Gereksiz olduğu için silinmiştir.

şaban torun · 12 Ocak 2018 11:53 tarihinde

merhaba benim sorunum diğer sayfadaki iki hücreyi art arda 0 0 yaparsam yazmış olduğum işlemde ilk sorgu doğru ondan sonraki kaç sıfır varsa ondan sonra hata veriyor yardımcı olurmusunuz başka bir kod kullana bilirmiyim eğer dışında kod :=EĞER(‘BÜYÜK PROJE bilgi’!CL3=1;DÜŞEYARA(B8;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CL4=2;DÜŞEYARA(B8+1;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ5=1;DÜŞEYARA(B8+2;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ6=1;DÜŞEYARA(B8+3;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ7=1;DÜŞEYARA(B8+4;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ4=1;DÜŞEYARA(B8+5;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ9=1;DÜŞEYARA(B8+6;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ10=1;DÜŞEYARA(B8+7;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ11=1;DÜŞEYARA(B8+8;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ12=1;DÜŞEYARA(B8+9;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ13=1;DÜŞEYARA(B8+10;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ14=1;DÜŞEYARA(B8+11;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ15=1;DÜŞEYARA(B8+12;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ16=1;DÜŞEYARA(B8+13;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ17=1;DÜŞEYARA(B8+14;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ18=1;DÜŞEYARA(B8+15;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ19=1;DÜŞEYARA(B8+16;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ20=1;DÜŞEYARA(B8+17;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3)))))))))))))))))))

RECEP DILGEC · 02 Ocak 2018 03:56 tarihinde

hocam benim istediğim formül her ayın 29 olduğunda tahakkuk sütununda 500 yazsın otamatik
bu konuda yardımcı olur mıusunuz saygılarımla

MUSTAFA · 25 Kasım 2017 19:13 tarihinde

Listeden karışık durumdaki 50,55,60 kg gibi farklı kilolardaki sporcuları yeni sayfada sıralamak istiyorum. Fikir verebilirmisiniz.

Kenan · 12 Kasım 2017 08:18 tarihinde

Selam,
Peki hücre rengi karşılaştırma sonucuna göre yeşil, değilse kırmızı ya nasıl dönüştürebiliriz.Örnek yazarmısın.tsk.

AHMET · 09 Kasım 2017 14:20 tarihinde

Hocam merhabalar. ben bir hücredeki yazı renginin kırmızı olup olmaması durumundan ödendi ya da ödenmedi sonucuna ulaşmak istiyorum. bu konuyla alakalı formül varmı? Teşekkürler

RAMAZAN Y · 03 Kasım 2017 14:24 tarihinde

MESELA 1-50 ARASI ZAYIFSIZ, 85 100 ARASI TAKDİR ALIR DİYE BELİRTTİĞİNİZ FORMULÜ KOPYALIYORUM HATA VERİYOR. YARDIMCI OLURMUSUNUZ
YAPMAK İSTEDĞİM ŞEY
1 İLE70 ARASI DÜZ
70 İLE85 ARSI TEŞEKKÜR
85 İLE 100 ARASI TAKDİR

    Dajder · 03 Kasım 2017 14:54 tarihinde

    Ramazan bey,
    Yukarıdaki daha önceden girmiş olduğum formülü tekrar kontrol ettim. Bir hata yok belki kopyala yapıştır yapıyorsanız çift tırnak işaretlerinde hata ile karşılaşabilirsiniz. Formülü yapıştırdıktan sonra tırnak işaretlerini elle tekrar düzenlerseniz muhtemelen problem kalmayacaktır. Geriye kalan formüldeki rakamları kendi kriterlerinize göre değiştirmenizdir.

Anonim · 03 Kasım 2017 11:07 tarihinde

=ÇOKEĞERORTALAMA(‘2017′!L3:L403;’2017′!G3:G403;”*Arıtma*”;’2017′!J3:J403;”bitti”;’2017′!I3:I403;”>=01.10.2017″;’2017’!I3:I403;”<=31.10.2017")
Formül ile Ekim ayı içerisinde G hücresinde Arıtma yazan, J hücresinde bitti yazan değerlerin ortalamasını almak istiyorum fakat ekim ayında istenilen değerler olmadığı için SAYI/0! hatası veriyor. Bunun yerine 0 yazmasını istiyorum.
Yardımcı olabilir misiniz.

Mustafa · 03 Kasım 2017 11:06 tarihinde

=ÇOKEĞERORTALAMA(‘2017′!L3:L403;’2017′!G3:G403;”*Arıtma*”;’2017′!J3:J403;”bitti”;’2017′!I3:I403;”>=01.10.2017″;’2017’!I3:I403;”<=31.10.2017")
Formül ile Ekim ayı içerisinde G hücresinde Arıtma yazan, J hücresinde bitti yazan değerlerin ortalamasını almak istiyorum fakat ekim ayında istenilen değerler olmadığı için SAYI/0! hatası veriyor. Bunun yerine 0 yazmasını istiyorum.
Yardımcı olabilir misiniz.

    Dajder · 03 Kasım 2017 14:52 tarihinde

    Mustafa bey,
    Eğer işleminiz de bu şekilde bir hata ile karşılaşıyorsanız hata veren yere 0 değeri vermek için
    =EĞERHATA(istediğiniz formülü buraya girin;0)
    şeklinde bir formül kullanabilirsiniz. Yani kendi formülünüzü yukarıda formülü girin dediğim yere girmeniz yeterlidir.

Sümeyye · 24 Ekim 2017 13:54 tarihinde

Merhaba ben size bir soru soracaktım size çok ihtiyacım var. Ben bir takvim hazırlayacağım bu takvim yıllar değiştimi günleri de değişecek mesela 24.10.2017 Salı’ya denk geliyorsa 24.10 2018 Çarşamba’ya denk geliyor ve bunda özel günleri hatırlatacağım yılları ben değiştirdikçe sayı girdiğim sürece yani günlerin ve özel günleri nasıl değişecek formülleriyle beraber bana yardımcı olursanız çok sevinirim staj gördüğüm yerde verilen bir ödevdir acil ilgilenirseniz sevinirim şimdiden teşekkür ederim.

    Dajder · 24 Ekim 2017 22:43 tarihinde

    Merhabalar Sümeyye,
    Maalesef bir yorum kısmında size takvim hazırlamak mümkün değil. Ancak isterseniz excel’in hazır takvim şablonlarından yararlanabilirsiniz. Yada tamamen 0’dan kendim yapmak istiyorum derseniz =HAFTANINGÜNÜ() formülünü biraz araştırıp bu işlemi gerçekleştirebilirsiniz. Aslında bu isteğiniz bana bu konuda bir yazı yazma isteği verdi, ancak şu an için maalesef buna pek vaktim yok.

Betül · 18 Ekim 2017 16:13 tarihinde

Merhaba Dilaver bey. =IF(‘[Ekim 2017.xlsx]24 Tv’!C36=0;””;'[Ekim 2017.xlsx]24 Tv’!C36) bu kodu anlamamda yardımcı olabilir misiniz rica etsem