Excel’de Eğer formülünün kullanımı (if) Resimli Anlatım – En kolay Anlatımı Bu Yazıda Bulacaksınız

Koşul formülü denilen “eğer” birçok kişiyi daha önce ki sıkıntılı ve zor anlatımlarla kafalarını karıştırıp içinden çıkamayanları korkutmakta. Bundan dolayı daha anlaşılır bir şekilde formülün kullanımını anlatıp bu kişilerin korkularını yenmesi ve aslında ne kadar pratik bir formül ve bir o kadar da kolay olduğunu görmeleri için bu yazıyı hazırladım.

Yazının uzun olması sakın sizi korkutmasın, olabildiğince anlaşılır ve basit olması için uzun bir anlatım metodu seçtim. Zaten kavradığınız noktaları atlayabilirsiniz. Yine de en azından bir kere yazının tamamını okumanız faydanıza olacaktır.

Öncelikle Eğer formülü nedir? Ne işe yarar? Kısaca ondan bahsedelim.

Aşağıda formülü anlamamız için değişik açıklamalar yaptım. Hepsi aslında aynı şeyi ifade eder.

  • Eğer formülü, iki veya daha fazla koşul olduğunda koşulların sonucuna göre yapılması gereken işlemi seçmemizi sağlar.
  • Diğer bir söyleyişle Eğer formülü, bir karşılaştırma sonucuna göre yapılacak işlemi seçmemizi sağlar.
  • Başka bir söyleyişle Eğer formülü, koşullara bağlı olarak farklı olasılıkların sonucunda yapılacak işlemi seçmemizi sağlar.

Formül hakkında bilmemiz gerekenler;

  • Eğer formülü tek başına kullanılmak zorunda değildir.
  • Eğer formülünde aynı anda 7 adet iç içe eğer formülü kullanılabilir.
  • Eğer formülünün içinde başka formüller kullanılabilmektedir.
  • Eğer formülü içinde tırnak içerisinde formül kullanılamaz. Tırnak içinde yazılanlar metin olarak algılanır.

Eğer Formülünün anlayabilmemiz için birden çok değişik şekilde gösterimini yapalım.

=EĞER(Koşul; Doğruysa; Yanlışsa)

=Eğer(Koşul; Şart sağlandı ise yapılacak işlem; Şart sağlanmadı ise yapılacak işlem)

=EğeR(Şart; Doğruysa değer; Yanlışsa değer)

=EğEr(Şart; Evet; Hayır)

 

Örnekle açıklayalım;

1. Örneğimiz; (Basit Eğer Formülü Kullanma Örneği)

Soru: En klasik eğer örneğini verelim. Başarılı ve başarısız öğrencilerin tespiti, sınav sonucu 50 ve üzeri ise başarılı değilse başarısızdır diyelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2>=50;”BAŞARILI”;”BAŞARISIZ”)

Bu formülde B2 hücresine girilen notun 50 geçer notu veya üzerini alıp almadığına bakıyoruz. B2>=50 Daha sonra bu koşula uyuyorsa BAŞARILI uymuyorsa BAŞARISIZ yazdırıyoruz.

eğer formülü 1

 2. Örneğimiz; (Basit Eğer Formülü Kullanma Örneği)

Soru: Yine basit bir örnek verelim. Maliyetinden düşük satışları tespit edip Kar ettiklerimize KAR, Zarar ettiklerimize de ZARAR yazalım.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2>C2;”ZARAR”;”KAR”)

aynı sonucu şu şekilde de bulabilirdik

=EĞER(B2<C2;”KAR”;”ZARAR”)

Bu formülde B2 hücresine girilen değerin C2 hücresine girilen değerden küçük mü büyük mü olduğuna baktık. Şayet küçükse KAR büyükse ZARAR yazdırdık.

eğer formülü 2

 

 3. Örneğimiz; (İç İçe Birden Fazla Eğer Formülü Kullanma Örneği)

Soru: İlk sorudaki Başarılı ve Başarısız olarak tespit etmiş olduğumuz öğrencilerin alacakları belgeleri aşağıdaki gibi tespit edelim.

– Aldığı not 50 puan veya düşükse KALDI yazsın

– Aldığı not 51 ile 70 puan arasında ise GEÇTİ yazsın

– Aldığı not 71 ile 85 puan arasında ise TEŞEKKÜR BELGESİ yazsın

– Aldığı not 86 ile 100 puan arasında ise TAKDİR BELGESİ yazsın

(Gerçekte belge puan durumlarını unuttuğum için rastgele belirledim).

 

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2<=50;”KALDI”;EĞER(B2<=70;”GEÇTİ”;EĞER(B2<=85;”TEŞEKKÜR BELGESİ”;”TAKDİR BELGESİ”)))

Bu formülde öncelikle B2 hücresine girilen değerin 70 puandan düşük ve eşit olup olmadığına baktık. Düşük veya eşitse KALDI yazdık, şayet değilse 70 puandan düşük olup olmadığına baktık düşük veya eşitse bu sefer GEÇTİ yazdırdık, yine değilse bu sefer de 85 puana eşit ve düşük olup olmadığına baktık. Düşükse TEŞEKKÜR BELGESİ yazdırdık. Şartı yine karşılamıyorsa bu sefer son seçenek olduğundan TAKDİR BELGESİ yazdırdık.

eğer formülü 3

Karışık gibi görünse de bir defa dikkatle incelediğinizde aslında aynı şeyi tekrar ettiğimizi ve olayın ne kadar basit olduğunu çok rahat anlayacaksınız.

4. Örneğimiz; (Farklı formüllerle Eğer formülünü birlikte kullanmak)

Soru: Hücreye girilmiş değerlerin 1 ila 20 değeri arasında olup olmadığını tespit edelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(VE(A2>1;A2<20);”Değer 1 ila 20 arasındadır”;”Değer belirlenen ölçülerin dışındadır”)

Bu formülde A2 hücresine girilen değerlerin 1 ila 20 arasında olup olmadığını kontrol ettik. Şayet 1 ila 20 arasında ise Değer 1 ila 20 arasındadır yazdırdık. Değilse Değer belirlenen ölçülerin dışındadır yazdırdık.

eğer formülü 4

 5. Örneğimiz; (Farklı formüllerle Eğer formülünü birlikte kullanmak)

Soru: Hücrelere girilmiş 1 ve 2 değerlerinin bulunduğu hücreleri tespit edelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(YADA(A2=1;B2=2);”BULUNDU”;”FARKLI”)

Bu formülde A2 hücre değerinin 1 olduğu ya da B2 hücre değerinin 2 olduğu durumda BULUNDU yazdık. Şayet her iki değerde farklı ise FARKLI yazdırdık.

eğer formülü 5

 

Umarım anlatımda başarılı olmuşumdur. Örnekleri bu formülde en çok kullanılabilecek örnekler hangileridir diye düşünerek yazmaya gayret ettim. Hala sıkıntı yaşadığınız durumları sormaktan lütfen çekinmeyin.

Bu dersin videosunu tam ekran yaparak aşağıdan net bir şekilde izleyebilirsiniz.

 



292 yorum

Mustafa AYDIN · 30 Eylül 2019 01:15 tarihinde

Merhabalar Dajder Bey,
Öncelikle böylesine faydalı ve güzel bir blog için teşekkür ederim. Benim sorum şu; Aşağıda bulunan rakamlar arasını gösterdiğinde o hücre değişik rakamları versin. Yani A hücresi 39 ise (Sıfır) 40 ile 60 arasında bir rakam ise 90, 60 ile 90 arasında ise 270 gibi gibi aşağıdaki şekilde olsun istiyorum yapamadım. METİN değil RAKAM olsun istiyorum nasıl yapabilirim. Belkide yanlış yerde arıyorum. Konu ile alakalı yardımlarınızı rica eder iyi günler dilerim. Saygılarımla.

40 Paket → 90 TL
60 Paket → 150 TL
90 Paket → 270 TL
130 Paket → 450 TL
150 Paket → 650 TL
200 Paket → 850 TL

    Dilaver AJDER · 30 Eylül 2019 13:44 tarihinde

    Mustafa bey;
    Eksik bir şey anlamadıysam; sorunuzu da eğer fonksiyonu ile çözmek gerekirse aşağıdaki gibi formülü uygularsanız sorununuz çözülecektir.

    =EĞER(K10<40;0;EĞER(K10<60;90;
    EĞER(K10<90;150;EĞER(K10<130;
    270;EĞER(K10<150;450;EĞER(K10
    <200;650;EĞER(K10>=200;850;
    "HATALI")))))))

      Mustafa AYDIN · 02 Ekim 2019 00:19 tarihinde

      Merhabalar Dilaver Bey, gerçekten harikasınız. Elinize sağlık, gün geçmiyor ki excelde yeni bir şeyler öğrenmiyorum. Harika bir program maşallah siz de çok hakimsiniz.

      Son bir sorumda neden formülün sonuna HATALI yazdınız acaba

        Dilaver AJDER · 07 Ekim 2019 12:09 tarihinde

        Teşekkür ederim. Harika olan sizlersiniz. Oradaki hatalı kısmını sadece veri girişinde bir hata varsa belirtmesi için yazdım. Örneğin rakam yerine metin girilirse HATALI yazacaktır.

Anonim · 18 Eylül 2019 15:28 tarihinde

Dilaver bey Merhaba
Excel dosyası göndermiştim. dönüş yapabilirmisiniz rica etsem

    Dilaver AJDER · 18 Eylül 2019 15:40 tarihinde

    Aynı dakikalar içinde yazıldığından dolayı öyle tahmin ediyorum ki mkurt…. mail adresli kişisiniz. Dosyanız bana ulaşmadı aynı zamanda ya mail adresiniz eposta almıyor yada yanlış zira 2 defa yazdığım halde hata mesajı alıyorum.

ERHAN KESİK · 15 Eylül 2019 17:19 tarihinde

merhaba Dilaver Bey;
bir sorum olacak tabloda mağaza isimleri var ve karşılarında tabloda günlük ciroları yazıyor sütunlarda şimdi satır ve sütun ekleme yapmadan ben buraya dolar yada euro eklemek istiyorum mesela yukarı bir buton olsa doları seçtiğimde dolar tl yi seçtiğimde Tl gösterse ve ben ciroları girebilsem ve aşağıya toplam yapacak mümkün müdür böyle bir şey?

fatih · 28 Temmuz 2019 21:40 tarihinde

Merhabalar,

Bir sorum olacak, bu konuda destek verebilir misiniz ?
Öncelikle destekleriniz için çok teşekkür ederim,

Sorunum aşağıdaki gibidir,

Excel üzerinde 2 farklı sayfa mevcuttur.
Sayfa 2 nin f3 alanına sayfa2 deki e3 karakterinin sayfa 1 deki g sütünündaki aratılarak eger sonuç doğru ise sayfa 1 deki b sütünündaki uygun alanın gelmesini istemekteyim.

bu durum olabilir mi ?

Murat · 16 Haziran 2019 14:36 tarihinde

Merhaba
Yardımcı olursanız çok sevinirim
İki değeri toplatıp sonuç 200 den büyük ise 200 çıkarsın küçük ise 200 eklesin istiyorum nasıl yaparız

    Dilaver AJDER · 16 Haziran 2019 16:21 tarihinde

    Merhaba Murat;
    İstemiş olduğunuz eğer formülü aşağıdaki gibidir. Burada değerlerin birisi A1 hücresinde diğeri B1 hücresinde olduğu varsayılmıştır.
    =EĞER((A1+B1)>=200;200;(A1+B1)+200)
    Kolay gelsin.

Muhammed · 18 Mayıs 2019 09:02 tarihinde

Dilaver Bey merhaba,

Yorumları okuduğumda tüm arkadaşlara tek tek yardımcı olmaya çalıştığınızı gördüm bunun için tüm arkadaşlar adına öncelikle teşekkür ederim. Benim de bir sorum olacak. İhale gibi bir düzen düşünün. Satır kısmına sırayla A4,A5,A6,A7 ….. diye devam eden malzeme listesi var diğer yanda sütun kısmında o malzemelere fiyat veren firmaların isimleri D3, D4,D5,D6….. gibisinden sıralanıyor. Hangi Firmanın o malzemeye daha uygun fiyat verdiğini nasıl belirleyebilirim. Örneğin hangi firma daha uygun verdiyse onu yeşil diğer firmaların fiyatlarını kırmızı işaretleyebilir miyiz?
Şimdiden vereceğiniz cevap için teşekkür ederim.
Saygılarımla

Bir cevap yazın

E-posta hesabınız yayımlanmayacak.

This site uses Akismet to reduce spam. Learn how your comment data is processed.