Excel’de Eğer formülünün kullanımı (if) Resimli Anlatım – En kolay Anlatımı Bu Yazıda Bulacaksınız

Koşul formülü denilen “eğer” birçok kişiyi daha önce ki sıkıntılı ve zor anlatımlarla kafalarını karıştırıp içinden çıkamayanları korkutmakta. Bundan dolayı daha anlaşılır bir şekilde formülün kullanımını anlatıp bu kişilerin korkularını yenmesi ve aslında ne kadar pratik bir formül ve bir o kadar da kolay olduğunu görmeleri için bu yazıyı hazırladım.

Yazının uzun olması sakın sizi korkutmasın, olabildiğince anlaşılır ve basit olması için uzun bir anlatım metodu seçtim. Zaten kavradığınız noktaları atlayabilirsiniz. Yine de en azından bir kere yazının tamamını okumanız faydanıza olacaktır.

Öncelikle Eğer formülü nedir? Ne işe yarar? Kısaca ondan bahsedelim.

Aşağıda formülü anlamamız için değişik açıklamalar yaptım. Hepsi aslında aynı şeyi ifade eder.

  • Eğer formülü, iki veya daha fazla koşul olduğunda koşulların sonucuna göre yapılması gereken işlemi seçmemizi sağlar.
  • Diğer bir söyleyişle Eğer formülü, bir karşılaştırma sonucuna göre yapılacak işlemi seçmemizi sağlar.
  • Başka bir söyleyişle Eğer formülü, koşullara bağlı olarak farklı olasılıkların sonucunda yapılacak işlemi seçmemizi sağlar.

Formül hakkında bilmemiz gerekenler;

  • Eğer formülü tek başına kullanılmak zorunda değildir.
  • Eğer formülünde aynı anda 7 adet iç içe eğer formülü kullanılabilir.
  • Eğer formülünün içinde başka formüller kullanılabilmektedir.
  • Eğer formülü içinde tırnak içerisinde formül kullanılamaz. Tırnak içinde yazılanlar metin olarak algılanır.

Eğer Formülünün anlayabilmemiz için birden çok değişik şekilde gösterimini yapalım.

=EĞER(Koşul; Doğruysa; Yanlışsa)

=Eğer(Koşul; Şart sağlandı ise yapılacak işlem; Şart sağlanmadı ise yapılacak işlem)

=EğeR(Şart; Doğruysa değer; Yanlışsa değer)

=EğEr(Şart; Evet; Hayır)

 

Örnekle açıklayalım;

1. Örneğimiz; (Basit Eğer Formülü Kullanma Örneği)

Soru: En klasik eğer örneğini verelim. Başarılı ve başarısız öğrencilerin tespiti, sınav sonucu 50 ve üzeri ise başarılı değilse başarısızdır diyelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2>=50;”BAŞARILI”;”BAŞARISIZ”)

Bu formülde B2 hücresine girilen notun 50 geçer notu veya üzerini alıp almadığına bakıyoruz. B2>=50 Daha sonra bu koşula uyuyorsa BAŞARILI uymuyorsa BAŞARISIZ yazdırıyoruz.

eğer formülü 1

 2. Örneğimiz; (Basit Eğer Formülü Kullanma Örneği)

Soru: Yine basit bir örnek verelim. Maliyetinden düşük satışları tespit edip Kar ettiklerimize KAR, Zarar ettiklerimize de ZARAR yazalım.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2>C2;”ZARAR”;”KAR”)

aynı sonucu şu şekilde de bulabilirdik

=EĞER(B2<C2;”KAR”;”ZARAR”)

Bu formülde B2 hücresine girilen değerin C2 hücresine girilen değerden küçük mü büyük mü olduğuna baktık. Şayet küçükse KAR büyükse ZARAR yazdırdık.

eğer formülü 2

 

 3. Örneğimiz; (İç İçe Birden Fazla Eğer Formülü Kullanma Örneği)

Soru: İlk sorudaki Başarılı ve Başarısız olarak tespit etmiş olduğumuz öğrencilerin alacakları belgeleri aşağıdaki gibi tespit edelim.

– Aldığı not 50 puan veya düşükse KALDI yazsın

– Aldığı not 51 ile 70 puan arasında ise GEÇTİ yazsın

– Aldığı not 71 ile 85 puan arasında ise TEŞEKKÜR BELGESİ yazsın

– Aldığı not 86 ile 100 puan arasında ise TAKDİR BELGESİ yazsın

(Gerçekte belge puan durumlarını unuttuğum için rastgele belirledim).

 

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2<=50;”KALDI”;EĞER(B2<=70;”GEÇTİ”;EĞER(B2<=85;”TEŞEKKÜR BELGESİ”;”TAKDİR BELGESİ”)))

Bu formülde öncelikle B2 hücresine girilen değerin 70 puandan düşük ve eşit olup olmadığına baktık. Düşük veya eşitse KALDI yazdık, şayet değilse 70 puandan düşük olup olmadığına baktık düşük veya eşitse bu sefer GEÇTİ yazdırdık, yine değilse bu sefer de 85 puana eşit ve düşük olup olmadığına baktık. Düşükse TEŞEKKÜR BELGESİ yazdırdık. Şartı yine karşılamıyorsa bu sefer son seçenek olduğundan TAKDİR BELGESİ yazdırdık.

eğer formülü 3

Karışık gibi görünse de bir defa dikkatle incelediğinizde aslında aynı şeyi tekrar ettiğimizi ve olayın ne kadar basit olduğunu çok rahat anlayacaksınız.

4. Örneğimiz; (Farklı formüllerle Eğer formülünü birlikte kullanmak)

Soru: Hücreye girilmiş değerlerin 1 ila 20 değeri arasında olup olmadığını tespit edelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(VE(A2>1;A2<20);”Değer 1 ila 20 arasındadır”;”Değer belirlenen ölçülerin dışındadır”)

Bu formülde A2 hücresine girilen değerlerin 1 ila 20 arasında olup olmadığını kontrol ettik. Şayet 1 ila 20 arasında ise Değer 1 ila 20 arasındadır yazdırdık. Değilse Değer belirlenen ölçülerin dışındadır yazdırdık.

eğer formülü 4

 5. Örneğimiz; (Farklı formüllerle Eğer formülünü birlikte kullanmak)

Soru: Hücrelere girilmiş 1 ve 2 değerlerinin bulunduğu hücreleri tespit edelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(YADA(A2=1;B2=2);”BULUNDU”;”FARKLI”)

Bu formülde A2 hücre değerinin 1 olduğu ya da B2 hücre değerinin 2 olduğu durumda BULUNDU yazdık. Şayet her iki değerde farklı ise FARKLI yazdırdık.

eğer formülü 5

 

Umarım anlatımda başarılı olmuşumdur. Örnekleri bu formülde en çok kullanılabilecek örnekler hangileridir diye düşünerek yazmaya gayret ettim. Hala sıkıntı yaşadığınız durumları sormaktan lütfen çekinmeyin.

Bu dersin videosunu tam ekran yaparak aşağıdan net bir şekilde izleyebilirsiniz.

 



247 yorum

Ahmet Ümit · 04 Haziran 2018 22:18 tarihinde

Merhaba Dilaver Bey;

A sütununda yazan değer 8’den küçükse A sütunundaki değeri;
8=<A<12 ise A-0,5 değerini
12=<A ise A-1 değerini
yazdırmak istiyorum. Yardımcı olur musunuz?
Teşekkürler.

    Dilaver AJDER · 04 Haziran 2018 23:51 tarihinde

    Merhabalar Ahmet bey,
    Size aşağıdaki gibi bir formül sanırım yardımcı olacaktır.
    =EĞER(VE(A1>=8;A1<12);A1-0,5;EĞER(12<=A1;A1-1;A1))

Kudret İdemci · 02 Haziran 2018 14:03 tarihinde

Bir takvim oluşturdum. Günler sütunu ve açıklama sütunu. Ayda ya da yılda kaç gün çalıştığımı görmek istiyorum. Açıklama sütununa gittiğim turların isimlerini yazıyorum. Belirlediğim bir sütuna Açıklama sütunundaki metni algılayıp Belirlediğim sütuna rakam olarak hep bir artırarak sayı belirtmesini istiyorum. Bu mümkün mü? Mesela A2 1 A2 2 ….A17 16 yazıyor (ay günleri), B2 Kapadokya B3 Kapadokya …B6 Kapadokya B7 Kapadokya. Belirlediğim AM5 e (4) yazmasını istiyorum ve bu her yazdığımda artsın istiyorum. Böyle bir formül mümkün mü? Teşekkür ederim

İbrahim ÇOLAK · 28 Mayıs 2018 12:22 tarihinde

Merhabalar;
B8 hücresinde 300 yazsın, D8 hücresinde 250 yazsın
E8 hücresinde istediğim sonuç; 300 >250 Uygundur.
yada;
B8 hücresinde 250 yazsın, D8 hücresinde 300yazsın
E8 hücresinde istediğim sonuç; 250 < 300 Uygun Değildir.
yani sonuç alanında her zaman B8 ve D8 hücrelerindeki verileri de yazsın. Bunu "Eğer" komutu ile sağlayabiliyor muyuz?

    Dilaver AJDER · 28 Mayıs 2018 13:08 tarihinde

    =EĞER(B8<300;B8&”< "&D8&" Uygun Değildir";B8&">“&D8&” Uygundur”)
    Sanırım eksik bir soru sordunuz ama yine de sorunuz bu şekilde ise formülü şeklinde yazabilirsiniz.

      İbrahim ÇOLAK · 28 Mayıs 2018 13:26 tarihinde

      Cevabınız için teşekkür ederim.
      Kendimi daha iyi ifade edebilmek için size iletişim bölümünden dosya ile birlikte mail attım.
      Şimdiden teşekkürler.

        Dilaver AJDER · 28 Mayıs 2018 14:11 tarihinde

        Mailinize örnek dosyanız hazırlanarak gönderilmiştir.

ABDULLAH KAYA · 22 Mayıs 2018 11:16 tarihinde

Hocam F4 HÜCRESİNDE 0 – 5 YIL YAZARSA H4 HÜCRESİ 16 YAZSIN.. F4 HÜCRESİ 5 – 15 YIL YAZARSA H4 HÜCRESİ 22 YAZSIN… F4 HÜCRESİ 15 – 30 YIL YAZARSA H4 HÜCRESİ 28 YAZSIN BU İŞLEMİ NASIL YAPABİLİRİM SAYGILAR.

    Dilaver AJDER · 26 Mayıs 2018 14:25 tarihinde

    Abdullah bey;
    İstediğiniz işlem için H4 hücresine
    =EĞER(VE(F4>=0;F4<5);16;EĞER(VE(F4>=5;F4<15);22;EĞER(VE(F4>=15;F4<30);28;”Hatalı Değer”)))
    şeklinde formül girebilirsiniz.

Yılmaz Kaydı · 11 Nisan 2018 12:58 tarihinde

merhaba,

17 tane ürün başlığı olan hücrelerin 8 tanesinin kdv si % 18, 1 tanesi % 8, 8 tanesinin kdv si % 0.
Ben burada tek tutar üzerinden hang, üründen satıldıysa ona göre hesaplama yapmak istiyorum. Yardımcı olabilir misiniz?

    enis · 24 Nisan 2018 10:05 tarihinde

    Bu formül için teşekkür ediyorum başarılarınzın devamını diliyorum 🙂

kenan · 04 Nisan 2018 02:01 tarihinde

ben C2 hücresine değer girdiğimde D3 kırmızı…D3 hücresine çıkış yazdığımda C2 hücresinin yeşil olmasını istiyorum. saatlerdir uğraşıyorum. genelde örnekler doğru yanlış veya büyüktür küçüktür gibi olduğundan çözemedim olayı..

Durmuş Demir · 03 Nisan 2018 18:17 tarihinde

Merhaba,
Çok teşekkür ederim. Emeğinize sağlık.

Hakan Erden · 29 Mart 2018 12:22 tarihinde

merhaba şöyle bi formül yazmak istedim yazamadım formül şu mesela A1 hücresi 1 ise B1 hücersi 6, A1 hücresi 2 ise B1 5, A1 hücresi 3 ise B1 4 olacak bu nu nasıl yaparım yardım edermisiniz

    Dajder · 30 Mart 2018 11:31 tarihinde

    Merhaba Hakan bey;
    B1 Hücresine =EĞER(A1=1;6;EĞER(A1=2;5;EĞER(A1=3;4;”A1 hücresine istenilen değer girilmedi”))) formülünü girebilirsiniz.

Anonim · 13 Mart 2018 00:00 tarihinde

bir harika çok faydalıyazıcıdan çıkartarak veya sayfayı indirerek kulanıla bilir bu bilgileri bu siteye sunan kişiye çok teşekkür ediriz

    Dajder · 30 Mart 2018 14:22 tarihinde

    Faydalı olduğuma çok sevindim.

Anonim · 12 Mart 2018 15:11 tarihinde

=EĞER(SAĞDAN(A1;3)=”150″;551;EĞER(SAĞDAN(A1;3)=”100″;551;511))

Anonim · 06 Mart 2018 14:41 tarihinde

yanlışşşşş 😀 😀 D:

    Anonim · 06 Mart 2018 14:41 tarihinde

    yanlış be yaaaaaa 😀 😀 😀

Dexter · 15 Şubat 2018 13:12 tarihinde

iki hücre de tarihi gösteriyorsa, A1 hücresindeki tarih B1 hücresinden büyük ise A1 hücresi yazsın, değil ise B1 yazsın dememiz için ne şekilde bir formül kullanmamız gerekmektedir?

Anonim · 19 Ocak 2018 14:14 tarihinde

excelde eğer formülü kullanarak 5 rakamın son üç hanesindeki rakamlar 150 veya 100 ise 551 yazmasını eğer son üç rakam 100 veya 150 değilse 511 yazmasını istiyorum formülü mailime gönderirseniz sevinirim. Şimdiden teşekkür ederim.

    Dajder · 07 Şubat 2018 11:51 tarihinde

    Sormuş olduğunuz soruya uygun bir formül aşağıdaki gibi olacaktır.
    =EĞER(YADA(SAĞDAN(A2;3)=”150″;SAĞDAN(A2;3)=”100″);551;511)

      emnş · 26 Şubat 2018 14:00 tarihinde

      yalan söleme gardas

      emnş · 26 Şubat 2018 14:00 tarihinde

      yalan söleme gardas

ucan ınek için bir cevap yazın Cevabı iptal et

E-posta hesabınız yayımlanmayacak.

%d blogcu bunu beğendi: