Excel’de Eğer formülünün kullanımı (if) Resimli Anlatım – En kolay Anlatımı Bu Yazıda Bulacaksınız

Koşul formülü denilen “eğer” birçok kişiyi daha önce ki sıkıntılı ve zor anlatımlarla kafalarını karıştırıp içinden çıkamayanları korkutmakta. Bundan dolayı daha anlaşılır bir şekilde formülün kullanımını anlatıp bu kişilerin korkularını yenmesi ve aslında ne kadar pratik bir formül ve bir o kadar da kolay olduğunu görmeleri için bu yazıyı hazırladım.

Yazının uzun olması sakın sizi korkutmasın, olabildiğince anlaşılır ve basit olması için uzun bir anlatım metodu seçtim. Zaten kavradığınız noktaları atlayabilirsiniz. Yine de en azından bir kere yazının tamamını okumanız faydanıza olacaktır.

Öncelikle Eğer formülü nedir? Ne işe yarar? Kısaca ondan bahsedelim.

Aşağıda formülü anlamamız için değişik açıklamalar yaptım. Hepsi aslında aynı şeyi ifade eder.

  • Eğer formülü, iki veya daha fazla koşul olduğunda koşulların sonucuna göre yapılması gereken işlemi seçmemizi sağlar.
  • Diğer bir söyleyişle Eğer formülü, bir karşılaştırma sonucuna göre yapılacak işlemi seçmemizi sağlar.
  • Başka bir söyleyişle Eğer formülü, koşullara bağlı olarak farklı olasılıkların sonucunda yapılacak işlemi seçmemizi sağlar.

Formül hakkında bilmemiz gerekenler;

  • Eğer formülü tek başına kullanılmak zorunda değildir.
  • Eğer formülünde aynı anda 7 adet iç içe eğer formülü kullanılabilir.
  • Eğer formülünün içinde başka formüller kullanılabilmektedir.
  • Eğer formülü içinde tırnak içerisinde formül kullanılamaz. Tırnak içinde yazılanlar metin olarak algılanır.

Eğer Formülünün anlayabilmemiz için birden çok değişik şekilde gösterimini yapalım.

=EĞER(Koşul; Doğruysa; Yanlışsa)

=Eğer(Koşul; Şart sağlandı ise yapılacak işlem; Şart sağlanmadı ise yapılacak işlem)

=EğeR(Şart; Doğruysa değer; Yanlışsa değer)

=EğEr(Şart; Evet; Hayır)

 

Örnekle açıklayalım;

1. Örneğimiz; (Basit Eğer Formülü Kullanma Örneği)

Soru: En klasik eğer örneğini verelim. Başarılı ve başarısız öğrencilerin tespiti, sınav sonucu 50 ve üzeri ise başarılı değilse başarısızdır diyelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2>=50;”BAŞARILI”;”BAŞARISIZ”)

Bu formülde B2 hücresine girilen notun 50 geçer notu veya üzerini alıp almadığına bakıyoruz. B2>=50 Daha sonra bu koşula uyuyorsa BAŞARILI uymuyorsa BAŞARISIZ yazdırıyoruz.

eğer formülü 1

 2. Örneğimiz; (Basit Eğer Formülü Kullanma Örneği)

Soru: Yine basit bir örnek verelim. Maliyetinden düşük satışları tespit edip Kar ettiklerimize KAR, Zarar ettiklerimize de ZARAR yazalım.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2>C2;”ZARAR”;”KAR”)

aynı sonucu şu şekilde de bulabilirdik

=EĞER(B2<C2;”KAR”;”ZARAR”)

Bu formülde B2 hücresine girilen değerin C2 hücresine girilen değerden küçük mü büyük mü olduğuna baktık. Şayet küçükse KAR büyükse ZARAR yazdırdık.

eğer formülü 2

 

 3. Örneğimiz; (İç İçe Birden Fazla Eğer Formülü Kullanma Örneği)

Soru: İlk sorudaki Başarılı ve Başarısız olarak tespit etmiş olduğumuz öğrencilerin alacakları belgeleri aşağıdaki gibi tespit edelim.

– Aldığı not 50 puan veya düşükse KALDI yazsın

– Aldığı not 51 ile 70 puan arasında ise GEÇTİ yazsın

– Aldığı not 71 ile 85 puan arasında ise TEŞEKKÜR BELGESİ yazsın

– Aldığı not 86 ile 100 puan arasında ise TAKDİR BELGESİ yazsın

(Gerçekte belge puan durumlarını unuttuğum için rastgele belirledim).

 

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(B2<=50;”KALDI”;EĞER(B2<=70;”GEÇTİ”;EĞER(B2<=85;”TEŞEKKÜR BELGESİ”;”TAKDİR BELGESİ”)))

Bu formülde öncelikle B2 hücresine girilen değerin 70 puandan düşük ve eşit olup olmadığına baktık. Düşük veya eşitse KALDI yazdık, şayet değilse 70 puandan düşük olup olmadığına baktık düşük veya eşitse bu sefer GEÇTİ yazdırdık, yine değilse bu sefer de 85 puana eşit ve düşük olup olmadığına baktık. Düşükse TEŞEKKÜR BELGESİ yazdırdık. Şartı yine karşılamıyorsa bu sefer son seçenek olduğundan TAKDİR BELGESİ yazdırdık.

eğer formülü 3

Karışık gibi görünse de bir defa dikkatle incelediğinizde aslında aynı şeyi tekrar ettiğimizi ve olayın ne kadar basit olduğunu çok rahat anlayacaksınız.

4. Örneğimiz; (Farklı formüllerle Eğer formülünü birlikte kullanmak)

Soru: Hücreye girilmiş değerlerin 1 ila 20 değeri arasında olup olmadığını tespit edelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(VE(A2>1;A2<20);”Değer 1 ila 20 arasındadır”;”Değer belirlenen ölçülerin dışındadır”)

Bu formülde A2 hücresine girilen değerlerin 1 ila 20 arasında olup olmadığını kontrol ettik. Şayet 1 ila 20 arasında ise Değer 1 ila 20 arasındadır yazdırdık. Değilse Değer belirlenen ölçülerin dışındadır yazdırdık.

eğer formülü 4

 5. Örneğimiz; (Farklı formüllerle Eğer formülünü birlikte kullanmak)

Soru: Hücrelere girilmiş 1 ve 2 değerlerinin bulunduğu hücreleri tespit edelim.

Cevap: Formülümüz aşağıdaki gibi olmalı

=EĞER(YADA(A2=1;B2=2);”BULUNDU”;”FARKLI”)

Bu formülde A2 hücre değerinin 1 olduğu ya da B2 hücre değerinin 2 olduğu durumda BULUNDU yazdık. Şayet her iki değerde farklı ise FARKLI yazdırdık.

eğer formülü 5

 

Umarım anlatımda başarılı olmuşumdur. Örnekleri bu formülde en çok kullanılabilecek örnekler hangileridir diye düşünerek yazmaya gayret ettim. Hala sıkıntı yaşadığınız durumları sormaktan lütfen çekinmeyin.

Bu dersin videosunu tam ekran yaparak aşağıdan net bir şekilde izleyebilirsiniz.

 



322 yorum

şaban torun · 12 Ocak 2018 11:53 tarihinde

merhaba benim sorunum diğer sayfadaki iki hücreyi art arda 0 0 yaparsam yazmış olduğum işlemde ilk sorgu doğru ondan sonraki kaç sıfır varsa ondan sonra hata veriyor yardımcı olurmusunuz başka bir kod kullana bilirmiyim eğer dışında kod :=EĞER(‘BÜYÜK PROJE bilgi’!CL3=1;DÜŞEYARA(B8;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CL4=2;DÜŞEYARA(B8+1;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ5=1;DÜŞEYARA(B8+2;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ6=1;DÜŞEYARA(B8+3;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ7=1;DÜŞEYARA(B8+4;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ4=1;DÜŞEYARA(B8+5;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ9=1;DÜŞEYARA(B8+6;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ10=1;DÜŞEYARA(B8+7;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ11=1;DÜŞEYARA(B8+8;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ12=1;DÜŞEYARA(B8+9;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ13=1;DÜŞEYARA(B8+10;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ14=1;DÜŞEYARA(B8+11;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ15=1;DÜŞEYARA(B8+12;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ16=1;DÜŞEYARA(B8+13;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ17=1;DÜŞEYARA(B8+14;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ18=1;DÜŞEYARA(B8+15;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ19=1;DÜŞEYARA(B8+16;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3);EĞER(‘BÜYÜK PROJE bilgi’!CJ20=1;DÜŞEYARA(B8+17;’BÜYÜK PROJE bilgi’!$BZ$3:$DL$206;3)))))))))))))))))))

RECEP DILGEC · 02 Ocak 2018 03:56 tarihinde

hocam benim istediğim formül her ayın 29 olduğunda tahakkuk sütununda 500 yazsın otamatik
bu konuda yardımcı olur mıusunuz saygılarımla

MUSTAFA · 25 Kasım 2017 19:13 tarihinde

Listeden karışık durumdaki 50,55,60 kg gibi farklı kilolardaki sporcuları yeni sayfada sıralamak istiyorum. Fikir verebilirmisiniz.

Kenan · 12 Kasım 2017 08:18 tarihinde

Selam,
Peki hücre rengi karşılaştırma sonucuna göre yeşil, değilse kırmızı ya nasıl dönüştürebiliriz.Örnek yazarmısın.tsk.

AHMET · 09 Kasım 2017 14:20 tarihinde

Hocam merhabalar. ben bir hücredeki yazı renginin kırmızı olup olmaması durumundan ödendi ya da ödenmedi sonucuna ulaşmak istiyorum. bu konuyla alakalı formül varmı? Teşekkürler

RAMAZAN Y · 03 Kasım 2017 14:24 tarihinde

MESELA 1-50 ARASI ZAYIFSIZ, 85 100 ARASI TAKDİR ALIR DİYE BELİRTTİĞİNİZ FORMULÜ KOPYALIYORUM HATA VERİYOR. YARDIMCI OLURMUSUNUZ
YAPMAK İSTEDĞİM ŞEY
1 İLE70 ARASI DÜZ
70 İLE85 ARSI TEŞEKKÜR
85 İLE 100 ARASI TAKDİR

    Dajder · 03 Kasım 2017 14:54 tarihinde

    Ramazan bey,
    Yukarıdaki daha önceden girmiş olduğum formülü tekrar kontrol ettim. Bir hata yok belki kopyala yapıştır yapıyorsanız çift tırnak işaretlerinde hata ile karşılaşabilirsiniz. Formülü yapıştırdıktan sonra tırnak işaretlerini elle tekrar düzenlerseniz muhtemelen problem kalmayacaktır. Geriye kalan formüldeki rakamları kendi kriterlerinize göre değiştirmenizdir.

Anonim · 03 Kasım 2017 11:07 tarihinde

=ÇOKEĞERORTALAMA(‘2017′!L3:L403;’2017′!G3:G403;”*Arıtma*”;’2017′!J3:J403;”bitti”;’2017′!I3:I403;”>=01.10.2017″;’2017’!I3:I403;”<=31.10.2017")
Formül ile Ekim ayı içerisinde G hücresinde Arıtma yazan, J hücresinde bitti yazan değerlerin ortalamasını almak istiyorum fakat ekim ayında istenilen değerler olmadığı için SAYI/0! hatası veriyor. Bunun yerine 0 yazmasını istiyorum.
Yardımcı olabilir misiniz.

Mustafa · 03 Kasım 2017 11:06 tarihinde

=ÇOKEĞERORTALAMA(‘2017′!L3:L403;’2017′!G3:G403;”*Arıtma*”;’2017′!J3:J403;”bitti”;’2017′!I3:I403;”>=01.10.2017″;’2017’!I3:I403;”<=31.10.2017")
Formül ile Ekim ayı içerisinde G hücresinde Arıtma yazan, J hücresinde bitti yazan değerlerin ortalamasını almak istiyorum fakat ekim ayında istenilen değerler olmadığı için SAYI/0! hatası veriyor. Bunun yerine 0 yazmasını istiyorum.
Yardımcı olabilir misiniz.

    Dajder · 03 Kasım 2017 14:52 tarihinde

    Mustafa bey,
    Eğer işleminiz de bu şekilde bir hata ile karşılaşıyorsanız hata veren yere 0 değeri vermek için
    =EĞERHATA(istediğiniz formülü buraya girin;0)
    şeklinde bir formül kullanabilirsiniz. Yani kendi formülünüzü yukarıda formülü girin dediğim yere girmeniz yeterlidir.

Sümeyye · 24 Ekim 2017 13:54 tarihinde

Merhaba ben size bir soru soracaktım size çok ihtiyacım var. Ben bir takvim hazırlayacağım bu takvim yıllar değiştimi günleri de değişecek mesela 24.10.2017 Salı’ya denk geliyorsa 24.10 2018 Çarşamba’ya denk geliyor ve bunda özel günleri hatırlatacağım yılları ben değiştirdikçe sayı girdiğim sürece yani günlerin ve özel günleri nasıl değişecek formülleriyle beraber bana yardımcı olursanız çok sevinirim staj gördüğüm yerde verilen bir ödevdir acil ilgilenirseniz sevinirim şimdiden teşekkür ederim.

    Dajder · 24 Ekim 2017 22:43 tarihinde

    Merhabalar Sümeyye,
    Maalesef bir yorum kısmında size takvim hazırlamak mümkün değil. Ancak isterseniz excel’in hazır takvim şablonlarından yararlanabilirsiniz. Yada tamamen 0’dan kendim yapmak istiyorum derseniz =HAFTANINGÜNÜ() formülünü biraz araştırıp bu işlemi gerçekleştirebilirsiniz. Aslında bu isteğiniz bana bu konuda bir yazı yazma isteği verdi, ancak şu an için maalesef buna pek vaktim yok.

Betül · 18 Ekim 2017 16:13 tarihinde

Merhaba Dilaver bey. =IF(‘[Ekim 2017.xlsx]24 Tv’!C36=0;””;'[Ekim 2017.xlsx]24 Tv’!C36) bu kodu anlamamda yardımcı olabilir misiniz rica etsem

    DAJDER · 19 Ekim 2017 10:04 tarihinde

    Merhaba Betül hanım,
    Formülünüz de bir hata var ancak açıklama olarak şöyle izah edebilirim.
    Ekim 2017 excel dosyasındaki 24 tv sayfasının c36 hücresindeki değer 0 sa boş bırak değilse aynı dosya aynı sayfa ve aynı hücredeki değeri bu formülü yazdığım yere getir demek istenmiş.

CenkK · 17 Ekim 2017 16:02 tarihinde

Hocam merhabalar, 4. örnekte kullandığınız =EĞER(VE(A2>1;A2<20);”Değer 1 ila 20 arasındadır”;”Değer belirlenen ölçülerin dışındadır”)formülüne ekleme yapılşabilir mi yine :EĞER ile olacak şekilde. Yani aşağıdaki formülün doğruluğunu kontrol etmneiz mümkünmüdür?
=IF(AND(D3="Teklif_Takibi";L2=10);C27;"MANUEL GİRİN!";OR(IF(AND(D3="Teklif_Takibi";L2=11);C28;"MANUEL GİRİN!")))
yani değişen şey olan L2 deki güncel değerler değiştikçe c27, c28, c29….. gidecek şekilde oromatik atama yapması gerekiyor.
L2=10 ise C27 ye , L2=11 ise C28 ye ,L2=12 ise C28'e şeklinde
Şimdiden teşekkürler.

    Dajder · 17 Ekim 2017 20:14 tarihinde

    Merhaba Cenk bey,
    Ekleme elbette yapılabilir. Ancak sizin gösterdiğiniz şekilde değil de iç içe eğer formülünü tekrarlayarak yapabilirsiniz.
    Yani formülünüz
    =EĞER(VE(D3=”Teklif_Takibi”;L2=10);C27;EĞER(VE(D3=”Teklif_
    Takibi”;L2=11);C28;EĞER(VE(D3=”Teklif_Takibi”;L2=12);C29;”MANUEL GİRİN!”))) şeklinde olmalı.

      CenkK · 23 Ekim 2017 14:16 tarihinde

      Merhabalar, Dilaver Bey,

      Çok teşekkür ederim. Çok yardımcı oldunuz.

Metin · 12 Ekim 2017 20:52 tarihinde

office2003 te koşullu biçimlendirmede 3 ten fazla fonksiyon yazdıramıyorum normal mi?

    Dajder · 13 Ekim 2017 10:29 tarihinde

    Elbette normal değil. 3 den fazla formül kullanabilirsiniz.

Eren Doğan · 24 Eylül 2017 01:48 tarihinde

Dilaver Bey
çalışma saatleriyle ilgili bir excel dosyası hazılamak isiyorum. öncelikle hücre biçimlendirden ss:dd şeklinde saat ayarlamasını yaptım.

şölye bir şablon oluşturdum ve saat hesaplarının böyle görünmesni istiyorum

tarih — işe giriş saati- işten çıkış saati — vardiya saati — çalışılan saat
01/09 19:00 00:00 05:00 04:30
02/09 19:00 22:30 03:30 03:30
03/09 19:00 05:00 10:00 09:00

istediğim şey
eğer çalışma saati (işe giriş – işten çıkış saati) 5 saatin altındaysa çalışılan saati aynen yazılsın
eğer çalışma saati 5 saat ise vardiya saatinin yarım saat eksik şekilde yazılsın (04:30 şeklinde)
eğer 5 saatten fazla ise 1 saat az yazsın (ör: 8 saat çalışılmışsa yan hücreye 7saat yazsın)

bunun için şöyle bi formül yazdım ancak istediğim sonucu alamadım
=EĞER(L65;L6-“01:00”)))

yardımcı olursanız sevinirim.

Saygılar
Eren Doğan

    Eren Doğan · 24 Eylül 2017 01:51 tarihinde

    formül eksik çıkmış

    =EĞER(L65;L6-“01:00”)))

    gerçi zaten doğrusunu siz yazacaksınız ama genede yazayım dedim
    teşekkürler

    Dajder · 25 Eylül 2017 21:01 tarihinde

    Eren bey Tarih saat fonksiyonlarında eğer vb.. fonksiyonlarda direk işlemi bu gösterdiğiniz şekilde yapamazsınız.
    Anlatımı uzun süreceğinden bu yorum kısmında cevaplamak yerine size excel olarak istediğinizi mail yoluyla gönderdim. Umarım işinizi görürsünüz.
    Diğer arkadaşlar cevabı bizde görseydik derlerse ayrıca konu olarak işleyebilirim.

Necipt · 20 Eylül 2017 16:14 tarihinde

İyi günlar. İki ayrı sayfada bir birinin aynı bilgileri içeren isim listesi var. Aralarındaki fark 1.listedeki isimler 2.listede farklı sıralarda. Yapmak istediğim. 1.listedeki ismi 2.listede bulup hizasında yazılı bilgileri karşılaştırıp doğru ise değişiklik yapmayacak. Yanlış ise 1.listedeki bilgiyi 2.listede yanlış olan bilgiyle değiştirecek. Dikkat edilmesi gereken 1.liste ile 2.liste farklı kitapların içinde.

    DAJDER · 22 Eylül 2017 14:41 tarihinde

    Bunun için eğer kullanmanıza gerek yok. =DÜŞEYARA(A1;Sayfa1!A:B;2;0) formülünü kullanabilirsiniz.

Anonim · 29 Ağustos 2017 16:36 tarihinde

Merhaba, excell de metni sütunlara ayırma işlemini yapmaya çalışıyorum. Elimde nerdeyse bi 10 000 satır var. Bu satırlardaki sayılarda noktayla virgülü değiştirmem gerekiyor. Metni sütunlara dönüştür dediğimde bu işlemi yapabiliyorum ancak 10 000 li satırlara gelindiginde 1000 li olan sayılarımda nokta ve virgül beraber olduğu için düzgün ayıramıyor ve yan sütuna değerleri atmaya başlıyor. Hücre biçimlendirmeden denediğimdede bir şey değimedi. Sorunlu kısımları hücre birleştirle halletmeye çalışıyorum ama uzun sürüyor. Metin halindeki listede tüm veriler çift tırnak ve virgülle ayrılmış durumda. O sorunlu 1000 li kısımların başına çift tırnak koyup ayırmayı denediğimde düzgün ayrıldığını fark ettim ama bu kadar uzun sayılar için bunu tek tek yapmam mümkün değil. Ne yapabilirm ? Teşekkür ederim şimdiden.

    Dajder · 31 Ağustos 2017 19:55 tarihinde

    Merhabalar,
    anladığım kadarı ile elle ondalık kısmı ayrılmış rakamlar var elinizde. Aslında excel’de ondalık kısımları belirten nokta ve virgül değerlerini değiştirebiliyorsunuz ama elle yapıldığı için bu çözüm işinize yaramaz. Bunun için rakamları sıralama işlemi yaptıktan sonra yani
    1,01
    10,01
    1000,01
    10000,01
    gibi sıralamaya soktuktan sonra “soldan” formülü ile belli karakterleri ayırmanız ve içlerinde bulunan nokta ve virgülleri ctrl + h ile temizlemeniz arından tekrar birleştirmeniz gerekmektedir. Sorunuzu yanlış anlamadıysam bu şekilde çözüme kavuşabilirsiniz.

Hüseyin · 25 Ağustos 2017 11:31 tarihinde

Merhaba Hocam;

benim formülüm şu olacak mesela g25,h25,I25 olma üzere yan yana 3 hücre olsun

=EĞER(H25>84;”GEÇTİ”;”KALDI”) diye bir formül yazdım bu formüle g25=”-” yani tire koyarsam I25 =SINAVA KATILMADI olması için ne yapmamız gerekiyor.formülü yazar mısınız

mehmet çakmak · 19 Ağustos 2017 14:02 tarihinde

Merhaba hocam benim a ve b iki satırım var a ve b satırına girilen sayıların toplamı 20 olduğunda c satırı 1 artsın.
örnek şöyle: a satırında 10 öğrenci b satırında 20 öğrenci c satırında 1 olacak
a satırı 15 öğrenci b satırı 28 öğrenci c satırı 2 olacak.

c satırı 20 eşit ve 20nın katı olduğunda her seferinde 1 artacak sımdıden tsk edıyorum.

İLKİN · 08 Ağustos 2017 20:41 tarihinde

Hocam iyi akşamlar. şimdi benim bir tane sayı sütunum var (200-150-400-300-0,37-0,99) gibi bir de B/A sütunum var yani son olarak iki satır şöyle oluyor(200-A, 150-B, 400-B, 300-B, 0,37-B, 0,99-B) ben bu iki satırda yer alan ‘B’ leri(-) ‘A’ ları (+) yapıcam. söyle bi fotmül yazdım ama olmadı
=EĞER(G2=”B”; “-“;”+”)

    Dajder · 15 Ağustos 2017 20:16 tarihinde

    Merhabalar,
    Formülünüz doğru gözüküyor. Ne gibi bir hata ile karşılaştınız.
    Excel Cevap

Tuna Arda · 04 Ağustos 2017 10:13 tarihinde

Değerli arkadaşlar bir formülün içinden çıkamadım yardımlarınzı rica ediyorum.

Elimdeki hazır hücre değerleri aşağıdaki gibi
A1=100
B1=18
C1=118 (A1+B1)
D1=35 (Kullandığım programın verdiği C1 Hücresinin 118 TL nin karşılığı Euro değer)

ihtiyacım olan ise
E1 = 100 Eğer B1 hücresi 0 ‘dan büyükse, D1 / 1,18 rakamının gelmesi, =Eğer(b1>0; d1/1,18) formülüyle bunu yaptım
ama aynı formülün devamına B1=0 ise D1 ‘e hiç bir işlem yapmadan 35 rakamını aynen getirmesini istiyorum işte bu olmuyor
Yardımlarını rica ediyorum.

    Dajder · 15 Ağustos 2017 20:25 tarihinde

    Tuna bey formülü şu şekilde düzenlemeniz yeterlidir.
    =EĞER(B1>0; D1/1,18;EĞER(B1=0;D1;”B1 0’dan küçük”))

MURAT YOSUNKAYA · 01 Ağustos 2017 17:25 tarihinde

arkadaslar mrb
a sutununda yer alan bilgilerin sonlarında ki (- den sonraki) bilgileeri ayırmak istiyorum . sağ dan kes formulu kulllanamıyorum çünkü karakter sayıları tutmuyor. yardımcı olursanız sevinirim teşekkürler. mail adresim muratyosunkaya@hotmail.com
örnek asagıdadır. teşekkürler.
7414.W6-DGN
7414.W6-SK
7414.W9-URT
7414.X1-SK
7414.X3-URT
7414.XK-ORJ
7414.XQ-YSG
7414.XR-ORJ
7414.XT-FT
7414.XW-FT
7414.XW-ORJ
7414.XX-SK
7414.XY-FT
7414.Y4-ORJ
7414.YA-FT
7414.YE-SK
7414.YJ-URT
7414.YL-ORJ-X
7414.YN-YSG
7414.YP-ORJ
7414.YQ-CRFL
7414.YT-CRFL
7414.YT-SFWY

Ahmet ÜTKÜR · 04 Temmuz 2017 01:30 tarihinde

Merhaba,
Bir konuda yardımcı olmanızı isteyeceğim.
Biz 4 kişilik bir ekiple hediyelik eşya yapıyoruz. Bir tablo yapmak istiyorum ama işin içinden çıkamadım. Örneğin kişiler a, b, c, d olsun. Bir de masraf havuzumuz var. Yapmak istediğim tabloda diyelim ki ürünü a kişisi yaptı (tabloda üretici sütununa ‘a’ yazdık). Ücret kısmına girilen değerimiz de x olsun (X değeri sabit değil, üründen ürüne değişiyor). A kişisi ürünü yaptığı için x’in %50’sini, masraf havuzu tüm x değerlerinin %20’sini, o üründe emeği geçmeyen ama sistemden yine de para alacak olan b, c, d kişileri x’in ayrı ayrı %10’unu alacak.
Böyle bir hakediş tablosunu nasıl oluşturabilirim. Bu konuda yardımlarınızı rica ediyorum. İyi çalışmalar.

    Aykut · 09 Temmuz 2017 12:03 tarihinde

    Merhaba Ahmet bey mail adresinizi yollarsanız size yardımcı olabilirim

Enes TEMEL · 03 Temmuz 2017 13:56 tarihinde

Merhaba; Örneğin Bir Sütunda %1, %8, ve %18 Olmak Üzere 3 Çeşit Kdv Oranları var, Hemen Yan Sütunda da KDV Tutarları Var,
Bu Kdv Oranlarına Bağlı Olma Koşulu İle en altta KDV Oranlarına Göre Kdv Tutarlarını Toplatmak İstiyorum (Eğer KDV Oranı % 1 İse Topla) %8 ise topla % 18 ise topla gibi, Yapıyorum ama hata veriyor Yarımcı Olursanız Sevinirim, Teşekkürler

Özlem · 22 Haziran 2017 11:45 tarihinde

Merhabalar,
Uzun bir sütunum var ve sütunlarda da a, b, c, d, e vb. ifadelerim var. Bu sütunun hepsi için eğer a ise, bir yere toplam yapılsın, diğerleri ise başka bir yere toplam yapılsın istiyorum. Kaç tane a kaç tane diğerlerinden var onları görmek için.
EĞER(A1:A90=”a” ; B1=B1+1 ; C1=C1+1) gibi bir formül yazıyorum ama hata veriyor. Yardımcı olur musunuz? Teşekkürler.

    Dajder · 22 Haziran 2017 14:53 tarihinde

    Merhaba Özlem hanım;
    Bunun birçok sayma yöntemi var. Ancak EĞER(A1:A90=”a” ; B1=B1+1 ; C1=C1+1) bu formül yanlış olur. Sadece formülün bulunduğu hücreye değer vermelisiniz Yani farklı bir hücreye =EĞERSAY(A:A;”a”) & ” adet a var” gibi daha sonra farklı bir hücreye de =EĞERSAY(A:A;”b”) & ” adet b var” gibi

sinem · 28 Mayıs 2017 00:51 tarihinde

Merhaba
Sorunum ; elimde iki ayri excel tablosu var
Biri full formülle olusturulmus .
A sutununda isimler asagi dogru siralı , sag tarafa dogru 1 ayin her gunu 1 2 3 4 … devam ediyor. ve formulle olusturulan rakamlar mevcut.
Bu rakamlar sistemden cektgm yeni dosya daki rakamlar ile guncellenmeli.
Bu islem icin nasil bi yol izlemeliyim

yardimci olurmusunuz 🙏

MEHMET DEMİRCİ · 16 Mayıs 2017 12:01 tarihinde

S.A. yapamadığım bir işlem. yardım bekliyorum.
A1 hücresinde, b1,c1 ve d1 hücrelerinin toplamı var.
n1 de son ödeme tarihi.
h1 hücresinde yapılan ödeme tutarı var.
yapılan ödeme eksik olduğu zaman E1 hücresinde ne kadar eksik olduğunu görmek istiyorum.
f1 hücresinde son ödeme tarihinden sonra yapılan ödemeye %5 ceza oranını görmek istiyorum.
g1 hücresinde yapılan ödeme fazla ise ne kadar fazla olduğunu görmek istiyorum.
En son olarak yine A1 de bütün bu işlemler yapıldıktan sonra ki toplam tutarı görmek istiyorum.
Hakkınızı şimdiden helal edin. inşaAllah çok saçma birşey sormamışımdır.

Bir cevap yazın

E-posta hesabınız yayımlanmayacak.

This site uses Akismet to reduce spam. Learn how your comment data is processed.